Ultimate PDF 7.0 avec Dolibarr 7.0.3 warning

Bonjour,
suite à une mise à jour de Dolibarr en 7.0.3 j’ai plein de message d’erreur du style:

Warning: Use of undefined constant _WITH_MERGED_PDF - assumed ‹ _WITH_MERGED_PDF › (this will throw an Error in a future version of PHP) in /home/wdfrggogkl/crm/htdocs/custom/ultimatepdf/class/actions_ultimatepdf.class.php on line 1411

ou encore lors de la génération d’une facture:

Warning: Use of undefined constant ULTIMATE_PDF_ - assumed ‹ ULTIMATE_PDF_ › (this will throw an Error in a future version of PHP) in /home/wdfrggogkl/crm/htdocs/custom/ultimatepdf/lib/ultimatepdf.lib.php on line 476

Warning: Use of undefined constant _DISABLESOURCEDETAILS - assumed ‹ _DISABLESOURCEDETAILS › (this will throw an Error in a future version of PHP) in /home/wdfrggogkl/crm/htdocs/custom/ultimatepdf/lib/ultimatepdf.lib.php on line 476

Warning: Use of undefined constant ULTIMATE_PDF_ - assumed ‹ ULTIMATE_PDF_ › (this will throw an Error in a future version of PHP) in /home/wdfrggogkl/crm/htdocs/custom/ultimatepdf/lib/ultimatepdf.lib.php on line 477

Warning: Use of undefined constant _ADDALSOTARGETDETAILS - assumed ‹ _ADDALSOTARGETDETAILS › (this will throw an Error in a future version of PHP) in /home/wdfrggogkl/crm/htdocs/custom/ultimatepdf/lib/ultimatepdf.lib.php on line 477

Est-ce que quelqu’un a une idée?

Merci d’avance et bonne journée

Salut Fyernaux,

apparemment, tu utilises le module tiers « ultimate PDF »: c’est lui qui déclenche tes erreurs.
Il faut directement voir avec le développeur de ce module, les coordonnées sont ici : https://www.dolistore.com/fr/modules/999-ultimatepdf-80.html?search_query=ULTIMATE&results=14

(Ce forum n’est consacré qu’à la version standard de dolibarr)

1 J'aime