Probleme d'erreur technique

Bonjour à tous,

Suite à la mise à jour version 10 je rencontre des problèmes à lier les factures clients et à voir les différents rapports .

Ci-dessous les differents message :

Warning: Declaration of modconsumption::init() should be compatible with DolibarrModules::init($options = ‹  ›) in /home/cpm2rp922077/public_html/dolibarr/custom/consumption/core/modules/modconsumption.class.php on line 0

Warning: Declaration of modconsumption::remove() should be compatible with DolibarrModules::remove($options = ‹  ›) in /home/cpm2rp922077/public_html/dolibarr/custom/consumption/core/modules/modconsumption.class.php on line 0

et ci dessous un autre message d’erreur .

Nom du rapport Résultat / Exercice, Par année
Mode de calcul Analyse des données journalisées dans le Grand livre.
(Voir analyse des paiements pour un calcul sur les paiements réels effectués même s’ils ne sont pas encore comptabilisés dans le Grand Livre.)
(Voir analyse des factures pour un calcul basé sur les factures enregistrées connues même si elles ne sont pas encore comptabilisées dans le Grand Livre.)
Période d’analyse
01/01/2016
… -
31/12/2019

Description Cela inclut les enregistrements dans votre Grand Livre ayant les comptes de comptabilité qui ont le groupe « EXPENSE » ou « INCOME » (Voir le menu Accountancy / Configuration / Plan comptable pour la configuration)
Généré le 05/10/2019 19:21

Dolibarr a détecté une erreur technique.
You use an experimental or develop level of features, so please do NOT report any bugs, except if problem is confirmed moving option MAIN_FEATURES_LEVEL back to 0.
Voici les informations qui pourront aider au diagnostic (Vous pouvez fixer l’option $dolibarr_main_prod sur ‹ 1 › pour supprimer quelques notifications):
Date: 20191005192106
Dolibarr: 10.0.2
Niveau de fonctionnalités: 1
PHP: 7.0.33
Server: Apache
OS: Linux web41.lws-hosting.com 3.10.0-962.3.2.lve1.5.26.2.el7.x86_64 #1 SMP Tue Jul 23 08:31:06 EDT 2019 x86_64
UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36

Url sollicitée: /dolibarr/compta/resultat/index.php?leftmenu=accountancy_report
Referer: https://m2r-proprete-sas.fr/dolibarr/compta/resultat/clientfourn.php?leftmenu=accountancy_report
Gestionnaire de menu: eldy_menu.php

Modules/Applications: user, syslog, societe, service, mailmanspip, gravatar, api, webservices, skype, geoipmaxmind, externalrss, ldap, fckeditor, adherent, expensereport, propal, datapolicy, expedition, ficheinter, categorie, incoterm, blockedlog, salaries, banque, prelevement, consumption, mydoli, ticket, accounting, tax, variants, stock, product, productbatch, debugbar, margin, loan, projet, supplier_proposal, contrat, resource, hrm, webservicesclient, documentgeneration, ftp, formstyler, agenda, mailing, barcode, export, cron, import, commande, workflow, don, ecm, facture, fournisseur, clicktodial, holiday, oauth, opensurvey, notification, paybox, printing
Type gestionnaire de base de données: mysqli
Requête dernier accès en base en erreur: SELECT b.doc_ref, b.numero_compte, b.subledger_account, b.subledger_label, pcg_type, date_format(b.doc_date,’%Y-%m’) as dm, sum(b.debit) as debit, sum(b.credit) as credit, sum(b.montant) as amount FROM llxa3_accounting_bookkeeping as b, llxa3_accounting_account as aa WHERE b.numero_compte = aa.account_number AND b.entity = 1 AND ( (pcg_type = ‹ EXPENSE ›) OR (pcg_type = ‹ INCOME ›)) AND fk_pcg_version = ‹ PCG99-BASE › AND b.doc_date >= ‹ 2016-01-01 00:00:00 › AND b.doc_date <= ‹ 2019-12-31 23:59:59 › GROUP BY b.doc_ref, b.numero_compte, b.subledger_account, b.subledger_label, pcg_type, dm
Code retour dernier accès en base en erreur: DB_ERROR_1267
Information sur le dernier accès en base en erreur: Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation ‹ = ›

je vous remercie d’avance pour l’aide que vous pourrez me fournir.

Merci d’avance

Salut M2R,

Pour les premières erreurs :

tu as apparemment un module qui pose problème : consumption
Il faut donc
- ou revenir à la version précédente de dolibarr
- ou désinstaller ce module si tu ne t’en sert pas
- ou regarder si une nouvelle version du module existe (compatible avec la version vers la quelle tu as migré)

Pour l’erreur au niveau de la compta :

tu as apparemment une table qui n’est pas au bon interclassement.
Lance le script de correction pour repasser toutes les tables dans le bon format :
tonurldedolibarr/install/repair.php?force_utf8_on_tables=confirmed


Autre remarques :

- tu es en MAIN_FEATURES_LEVEL=1
repasse en 0 si ça n’est pas utile. (cela active des fonctionnalités qui ne sont pas forcément stable)

- tu as activé un nombre de module très impressionnant, je doute fortement que tu les utilises tous…
désactive ceux qui ne te sont pas utiles

1 J'aime

Bonjour

Le passage de 9 à 10 peux rendre des modules incompatibles voire non fonctionnels à cause d’une comparaison de numéro de version mal réalisée…
Si un module teste DOL_VERSION < 8 avec la v10 il te dira que c’est bien inférieur…comparaison de chaine de caractère
Si un module teste (int) DOL_VERSION < 8 (ou float) comparaison de nombres, le test sera ok

Donc en V10 mettez à jour vos modules…

Fred

1 J'aime