Module Builder ne genere pas les left menu

bonjour,
v18.0.2 php 7.4, a la creation d’un objet les menus de gauche ne sont pas creer

merci dee votre aide

Bonjour,

Le right arrow du bignou needs activation

2 « J'aime »

thank you can you elaborate

Bonjour @medbenkrid,

Pourriez-vous nous faire une capture d’écran de la page « Menus » ou nous indiquer les éléments du fichier XXX.class.php, après

		/* BEGIN MODULEBUILDER TOPMENU */

Merci !

bonsoir a tous ( Kusco medbenkrid ,
Moi aussi j’ai le meme probleme . je suis en train de créer un module mais j’ai ce probleme d’ affichage

Bonjour,

Il y a plusieurs soucis pour moi :
La position n’est pas en français, mais en anglais, donc left et top. Pour le menu parent, le codage me semble erroné également.

Voici un exemple ci-dessous pour y voir plus clair :


j’ai changer de nom d’application et voila
j’utilise la version 18.0.2

j’ai trouver la solution qui etait lié a la permission. c’etait comme ci " ‹ perms ›=>‹ 1 › " et je l’ai remplacé par
‹ perms ›=>‹ $user->hasRight(« agvattes », « attestation », « read ») ›,

1 « J'aime »

Bonjour,
J’ai le meme souci. J’utilise le builder pour la premiere fois et pas de left menu.
J’ai créé un nouveau module blog tout simple.
Dolibarr 18.0.4
Adjayi pourrais tu etre plus précis sur ta solution stp ?
Merci

Re-bonjour,

Je me permets de copier cette réponse de ‹ Sotica95 › qui a résolu mon prob.

J’ai trouvé pourquoi.
Le module builder, sur la génération du menu left maitre, rempli la ligne enabled comme suit :

'enabled'=>'$conf->testmodule->enabled',

il suffit de remplacer « testmodule » par le nom de votre module et le menu apparaît enfin. Etonnamment, les sous menus ne sont pas affecté par ce soucis, leurs lignes enabled sont correctes.

Jf

1 « J'aime »

Bonsoir
Milles excuses bonne et heureuse année de santé surtout. je t’apporte plus de précision afin de permettre à d’autres personnes de résoudre ce probleme.

enfait; j*ai trouvé, dans le fichier du menu a partir de la ligne 366 il faut changer les Testmodule par le non du module