Installation impossible Debian Bullseye

Salut à tous,
Je reviens vers vous, car malgré un souci résolu sous debian 10, je n’arrive pas à compléter mon installation sous debian 11, j’ai été obligé d’installer la version testing car l’ordi que j’ai acheté était trop récent pour la dernière version stable.
Alors donc, je suis coincé au même endroit que la dernière fois, à savoir, la page internet de configuration de dolibarr. J’ai créer un utilisateur et une base de donnée mysql (mariadb) mais il refuse de reconnaître ma base de donnée.

    Enregistrement du fichier de configuration /etc/dolibarr/conf.php	Ok
Rechargement des paramètres depuis le fichier de configuration.	Ok

Échec de la création de la base 'surlacordecompta'.

Si la base existe déjà, revenez en arrière et désactiver l'option "Créer la base de données".

et pour la base MariaDB

MariaDB [(none)]> show grants for "surlacorde"@"localhost";
+-------------------------------------------------------------------------------------------------------------------+
| Grants for [email protected]                                                                                   |
+-------------------------------------------------------------------------------------------------------------------+
| GRANT USAGE ON *.* TO `surlacorde`@`localhost` IDENTIFIED BY PASSWORD '********' |
| GRANT ALL PRIVILEGES ON `surlacordecompta`.* TO `surlacorde`@`localhost`                                          |
+-------------------------------------------------------------------------------------------------------------------+
2 rows in set (0.000 sec)

merci d’avance.

Bonjour,

Si vous avez créé la base avant de lancer l’installation, il faut décocher (ou laisser décocher) la case ‹ Créer la base › pendant l’installation.

Cdt

bonsoir,
j’ai à peu prêt tout essayé, avec sans création de database, avec ou sans création d’un utilisateur
Rien y fait.
quand je décoche la case créer la base de donnée cela donne ça :

Access denied for user 'root'@'localhost'

La connexion à la base de données a échoué: les paramètres de l'hôte ou du super utilisateur doivent être erronés.

quand je laisse vide le nom du port j’ai cela :

Fichier de configuration

| --- | --- |
|Rechargement des paramètres depuis le fichier de configuration.|
|Utilisateur de création : surlacorde|Erreur: 0|
|Échec de la création de la base 'surlacordecompta'.

Si la base existe déjà, revenez en arrière et désactiver l'option "Créer la base de données".|

quand je laisse la case créer la base de donnée mais que je supprime le nom du port j’ai ceci :

   Connexion au serveur réussie mais base 'surlacordecompta' introuvable.

Revenez en arrière et vérifiez / corrigez les paramètres.

et vous renseignez quoi dans la zone du bas, administrateur bdd?

je touche pas à l’identifiant, de toute façon je peux pas, et je met le mdp de l’utilisateur que j’ai créer sous mysql. J’ai aussi essayé avec le mdp de mon ordi au cas ou. J’avoue que cette page là est très confuse pour moi, j’arrive pas à comprendre si il faut remplir ou pas des trucs et je n’ai trouvé aucunes infos là dessus. entre le fait qu’il (dolibarr) propose de créer la base de donnée mais que finalement il faut passer par mysql et le super utilisateur c’est pas clair s’t’affaire !!

Bonsoir,

il semblerait que la base soit créee (surlacordecompta) :

mais quand vous cherchez à lancer sans création de la db vous avez le message :

on voit donc que le user database que vous utilisez pour l’install (root) est différent de celui qui a les droits sur la base (surlacorde), donc l’échec est prévisible. il faut spécifier le user declaré quand vous essayez d’installer ou donner les droits sur la base à l’utilisateur root (root MariaDB, en spécifiant le password de ce user)

Bonjour
Merci de ces réponses, mais entre les root user et database , je m’y perd un peu.
Je vais reprendre depuis le début.
Via le terminal j’ai créer une database qui s’appelle surlacordecompta, puis un utilisateur qui s’appelle surlacorde avec un mdp, j’ai donné les droits à l’utilisateur sur la database, donc là pour moi tout va bien. La seul question c’est, quand vous parlez de root, c’est le root de mon os ??

Mais ensuite lorsqu’il faut remplir la page http://localhost/dolibarr/install/fileconf.php?selectlang=fr_FR c’est là que rien ne va.
Je vais mettre une image pour qu’on se comprenne mieux parce que sinon on va encore s’emmêler les pinceaux .

bonjour,
la base ‹ surlacordecompta › existe déjà. Le user ‹ surlacorde › également et il a les droits sur la base déjà créée. Pourquoi dans ce cas cocher la case ‹ créer le propriétaire ou lui affecter les droits › ?
Cela semble inutile et vous semblez ne pas connaitre le mot de passe ‹ superutilisateur › mysql (mariaDB) : ce login/mot de passe vous sera nécessaire uniquement si vous souhaitez accéder directement à votre serveur mysql (il est possible que cela soit root sans mot de passe, mais cela reste à confirmer)
Bon courage

bonsoir, la case créer le propriétaire est décoché, c’est juste qu’au moment de l’impression d’écran, je n’avais pas fait attention qu’elle était coché.
Je vous montre mes deux dernières tentatives


qui répond ceci :

et en refaisant l’essai en supprimant les infos du port, car il est noté que :

Port du serveur. Ne rien mettre si inconnu.


j’ai cela :

C’est le fait que ma database existe et ne soit pas reconnu le pb non ??
D’ailleurs si je refait un test avec root cela confirme :


donne
Capture d’écran de 2021-03-14 20-30-18

Dolibarr ne veux ni me créer une base de donnée ni utiliser celle que j’ai précédemment créer.

Avez-vous fait mysql_secure_installation avec le compte root, pour paramétrer un administrateur global mysql ?

Bonjour
J’ai fait la commande, à l’aveugle je l’avoue, j’ai rentré yes à chaque demande.

[email protected]:~# mysqladmin -u root -p version
Enter password: 
mysqladmin  Ver 9.1 Distrib 10.5.9-MariaDB, for debian-linux-gnu on x86_64
Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Server version		10.5.9-MariaDB-1
Protocol version	10
Connection		Localhost via UNIX socket
UNIX socket		/run/mysqld/mysqld.sock
Uptime:			20 min 20 sec

Threads: 1  Questions: 73  Slow queries: 0  Opens: 32  Open tables: 25  Queries per second avg: 0.059

Toujours bloqué au même stade.

Et bien refaite la commande en ouvrant les yeux !! :wink:

ok mais ça m’avancera à quoi, je pige rien aux lignes de commande, et encore moins quand c’est en anglais !

[email protected]:~# mysql_secure_installation

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user. If you've just installed MariaDB, and
haven't set the root password yet, you should just press enter here.

Enter current password for root (enter for none): 
OK, successfully used password, moving on...

Setting the root password or using the unix_socket ensures that nobody
can log into the MariaDB root user without the proper authorisation.

You already have your root account protected, so you can safely answer 'n'.

Switch to unix_socket authentication [Y/n] n       
 ... skipping.

You already have your root account protected, so you can safely answer 'n'.

Change the root password? [Y/n] y
New password: 
Re-enter new password: 
Password updated successfully!
Reloading privilege tables..
 ... Success!


By default, a MariaDB installation has an anonymous user, allowing anyone
to log into MariaDB without having to have a user account created for
them.  This is intended only for testing, and to make the installation
go a bit smoother.  You should remove them before moving into a
production environment.

Remove anonymous users? [Y/n] y
 ... Success!

Normally, root should only be allowed to connect from 'localhost'.  This
ensures that someone cannot guess at the root password from the network.

Disallow root login remotely? [Y/n] y
 ... Success!

By default, MariaDB comes with a database named 'test' that anyone can
access.  This is also intended only for testing, and should be removed
before moving into a production environment.

Remove test database and access to it? [Y/n] y
 - Dropping test database...
 ... Success!
 - Removing privileges on test database...
 ... Success!

Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.

Reload privilege tables now? [Y/n] y
 ... Success!

Cleaning up...

All done!  If you've completed all of the above steps, your MariaDB
installation should now be secure.

Thanks for using MariaDB!
[email protected]:~# mysqladmin -u root -p version
Enter password: 
mysqladmin  Ver 9.1 Distrib 10.5.9-MariaDB, for debian-linux-gnu on x86_64
Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Server version		10.5.9-MariaDB-1
Protocol version	10
Connection		Localhost via UNIX socket
UNIX socket		/run/mysqld/mysqld.sock
Uptime:			20 min 20 sec

Threads: 1  Questions: 73  Slow queries: 0  Opens: 32  Open tables: 25  Queries per second avg: 0.059
[email protected]:~# mysql_secure_installation

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user. If you've just installed MariaDB, and
haven't set the root password yet, you should just press enter here.

Enter current password for root (enter for none): 
OK, successfully used password, moving on...

Setting the root password or using the unix_socket ensures that nobody
can log into the MariaDB root user without the proper authorisation.

You already have your root account protected, so you can safely answer 'n'.

Switch to unix_socket authentication [Y/n] y
Enabled successfully!
Reloading privilege tables..
 ... Success!


You already have your root account protected, so you can safely answer 'n'.

Change the root password? [Y/n] y
New password: 
Re-enter new password: 
Password updated successfully!
Reloading privilege tables..
 ... Success!


By default, a MariaDB installation has an anonymous user, allowing anyone
to log into MariaDB without having to have a user account created for
them.  This is intended only for testing, and to make the installation
go a bit smoother.  You should remove them before moving into a
production environment.

Remove anonymous users? [Y/n] y
 ... Success!

Normally, root should only be allowed to connect from 'localhost'.  This
ensures that someone cannot guess at the root password from the network.

Disallow root login remotely? [Y/n] y
 ... Success!

By default, MariaDB comes with a database named 'test' that anyone can
access.  This is also intended only for testing, and should be removed
before moving into a production environment.

Remove test database and access to it? [Y/n] y
 - Dropping test database...
 ... Success!
 - Removing privileges on test database...
 ... Success!

Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.

Reload privilege tables now? [Y/n] y
 ... Success!

Cleaning up...

All done!  If you've completed all of the above steps, your MariaDB
installation should now be secure.

Thanks for using MariaDB!

voila j’ai refais, tout est un succès , à part que ça n’a rien changé sur mon instal dolibarr, toujours le même souci.

Faites vous aider en local par un informaticien.
Bonne journée.

Ouais, merci quand même.
Un dernier détail/indice, j’ai pas le même nombre ni type d’utilisateur quand je tape la commande
select user, host from mysql.user;

sur ma machine en debian 10 (celle sur laquelel j’ai réussi à installer dolibarr) j’ai :

MariaDB [(none)]> select user, host  from mysql.user;
+------------+-----------+
| user       | host      |
+------------+-----------+
| root       | localhost |
| surlacorde | localhost |
+------------+-----------+
2 rows in set (0.000 sec)

et sur l’actuelle ou je galère j’ai :

MariaDB [(none)]> select user, host  from mysql.user;
+------------------+-----------+
| User             | Host      |
+------------------+-----------+
| mariadb.sys      | localhost |
| mysql            | localhost |
| root             | localhost |
| surlacorde       | localhost |
+------------------+-----------+
  4 rows in set (0.002 sec)

bonjour,

si vous avez le user/pasword pour le compte root MariaDb , pourquoi essayer de créer la base avant l’installation de dolibarr ? vous dites ne pas être adepte de la ligne de commande et de l’anglais, donc pourquoi ne pas laisser l’install de dolibarr faire tout à votre place ? sinon, comme suggéré par gaecCAB faites vous aider localement.
bon courage,

Salut à tous,
J’ai enfin réussi à installer dolibarr, pour infos pour ceux qui comme moi ne comprennent rien à la fameuse page de configuration voici les données que j’ai misent :

Nom del a base de donnée : celle créer dans Mariadb
type du pilote: ne rien changer
serveur de base de donnée : ne rien changer
port : ne rien changer
prefixe des tables : ne rien changer
Créer la base de donnée : décocher puisque nous avons déjà créer cette base via MariaDB
identifiant : celui de la base de donnée
mdp
Créer le propriétaire ou lui affecter les droits : oui
mdp : celui du root dans mariaDB

aller je passe le sujet en résolu et vais en ouvrir un autre car je n’arrive pas à effectuer une restauration à partir d’une base sur un autre ordi.

1 « J'aime »