Envoi de mail via Dolibarr considéré comme SPAM - FROM_EXCESS_BASE_64

Bonjour,

je vous soumets ici un problème que j’ai depuis très longtemps avec l’envoi des emails issu directement de Dolibarr
Mes emails sont à 60 % considérés comme spam et n’arrivent pas du tout au destinataire (même pas dans leur spams …)

J’ai fait quelques recherches avec mon hébergeur (o2switch) pour voir si cela ne provenait pas d’un problème de leur côté et nous avons des comparaisons entre un email envoyé via SMTP d’une messagerie classique et le même email envoyé via Dolibarr (avec le même paramétrage SMTP)
Nous avons constaté que Dolibarr transformait le header du mail et déclenchait la règle de sécurité suivante : FROM_EXCESS_BASE64

FROM_EXCESS_BASE64 indique un encodage en base64 inutile, générant un score de SPAM élevé.

J’ai cherché et je ne pense pas que nous ayons la main pour modifier cette méthode de création ou d’encodage des headers dans le paramétrage.
Aussi je fais appel à vous pour savoir si quelqu’un peut avoir une idée de la solution à trouver pour éviter que les emails qui partent de Dolibarr soit encodés inutilement de cette façon …

Merci par avance

1 « J'aime »

Bonjour
Que le header soit différent, c’est normal puisque pas le même outil.
Maintenant il faut regarder le contenu de vos mail aussi. Y a t-il des images logo etc intégrées ? Distantes ?
J’utilise Dolibarr pour envoyer TOUS mes mails d’entreprise et aucun souci.
Voir ce qui gène précisément o2switch aussi.
@+

Bonjour,
merci beaucoup pour le retour
dans mes emails il y a généralement une pièce jointe (qui correspond au document léger en pdf issu de Dolibarr - comme une demande de prix à un fournisseur par exemple), mais aucune image ou aucun lien externe ajouté
J’ai remarqué que les problèmes arrivaient la plupart du temps pour des fournisseurs basés à l’étranger (mais pas que, certains français aussi …)
o2switch a vérifié la configuration, et mes envois de mails et m’indique que c’est simplement le header généré par Dolibarr avec encodage apparemment inutile FROM_EXCESS_BASE_64 qui fait ressortir les emails de Dolibarr avec une suspicion de spams plus élevée …
ce que j’aimerais comprendre, c’est pourquoi il y a un encodage du header en base 64, et pourquoi il « serait » inutile dans ce cas. Et bien sûr comment il serait possible d’avoir une option pour modifier cet encodage ? encore merci

Bonjour,

Comme @Philazerty j’envoie tous mes mails depuis Dolibarr sans aucun souci. Je suis chez Informaniak mais j’avais aussi tester O2Switch et pas de souci non plus.
Je pense plutôt que vous avez un souci de configuration de votre serveur mail.

Faite un test avec https://www.mail-tester.com/ depuis votre Dolibarr et regarder ce que ca donne.
Surement des enregistrement DKIM / SPF / Dmarc manquant ou mal configuré…

Bonne journée

1 « J'aime »

Bonsoir,
De mon coté plus de problèmes, et ceux que j’avais n’étaient pas comme les votres. J’héberge mon Dolibarr sur un NAS Synology, et il possède un courriel Exchange365.
Après quelques réglages coté DNS, les courriels sont désormais bien acceptés par les serveurs des destinataires.

Cordialement,

Bonjour

Quelle méthode d’envoi ?

avec php mail ou smtps, c’est tout le sujet qui est encodé…
image

Fred

Bonjour,

merci beaucoup pour le retour

le paramétrage est en smtp

Je reprécise que les DKIM / SPF / Dmarc sont corrects sur les messages envoyés, j’ai vérifié tout cela avec o2switch
leur conclusion est bien un problème d’encodage en base 64 qui serait détécté
Nous avons vérifié dix fois que la configuration du serveur mail était correcte.

Est-ce qu’il est possible d’avoir une option dans Dolibarr pour modifier le type d’encodage ? peut-être dans une évolution ?

Merci à vous

Bonjour,
est-ce que le type d’encodage des messages en base 64 est nécessaire à Dolibarr ?
Aurais-t-on la possibilité de le paramétrer ?

Les problèmes d’envois d’emails subsistent et o2switch indique qu’ils n’ont pas de prise sur l’encodage qui sort de Dolibarr

Merci à vous

Bonjour,

Avez-vous essayé d’envoyer les emails avec « Swift Mailer socket library » plutôt que « SMTP/SMTPS socket library » ?

Bonjour,

non effectivement je n’ai pas essayé cette option car je ne la connaissais pas
Je vais la tester, j’ai vu qu’il y avait des champs de paramétrage DKIM supplémentaires avec cette librairie

Par contre je ne sais pas si c’est une solution pérenne car apparemment elle n’est plus maintenue, voici la mention sur leur site :
Swiftmailer is not maintained anymore . [Use Symfony Mailer]

Je vous tiens au courant si c’est mieux ou non

Merci pour cette suggestion en tout cas