Compatibilité alpiroc et dolibarr V10

Bonjour,
je viens de passer de dolibarr 7 a dolibarr 10 et mon module alpiroc 1.3.0 ne fonctionne plus, voila le message :
Fatal error : Uncaught InvalidArgumentException in /home/gerfrphvki/dolibarr/dolibarr/alpiroc/core/modules/fonctions/function.php:46 Stack trace: #0 /home/gerfrphvki/dolibarr/dolibarr/alpiroc/core/modules/facture/doc/pdf_alpiroc_fact.modules.php(2111): pdfBuildThirdpartyNameAlpiroc(NULL, Object(Translate)) #1 /home/gerfrphvki/dolibarr/dolibarr/alpiroc/core/modules/facture/doc/pdf_alpiroc_fact.modules.php(396): pdf_alpiroc_fact->_pagehead(Object(TCPDI), Object(Facture), 1, Object(Translate), NULL) #2 /home/gerfrphvki/dolibarr/dolibarr/core/class/commonobject.class.php(4575): pdf_alpiroc_fact->write_file(Object(Facture), Object(Translate), ‹  ›, 0, 0, 0, NULL) #3 /home/gerfrphvki/dolibarr/dolibarr/compta/facture/class/facture.class.php(4174): CommonObject->commonGenerateDocument(‹ core/modules/fa… ›, ‹ alpiroc_fact ›, Object(Translate), 0, 0, 0, NULL) #4 /home/gerfrphvki/dolibarr/dolibarr/compta/facture/card.php(1963): Facture->generateDocument(‹ alpiroc_fact ›, Object(Translate), 0, 0, 0) #5 {main} thrown in /home/gerfrphvki/dolibarr/dolibarr/alpiroc/core/modules/fonctions/function.php on line 46

Je sais qu’Alpiroc n’est plus maintenu mais je suis coincé car j’ai besoin d’Alpiroc ou d’un equivalent en tant qu’artisan pour faire mes devis et factures, azur et crabe sont vraiment trop limités?
Est ce faisable d’adapter alpiroc? Ou bien quel module ferait le meme boulot qu’Alpiroc?
Je vous remercie,
Yann

Bonjour Yann,

Il y a ceci, mais uniquement pour azur. Sinon il y a sous-total.
Tout cela sur le store.

Frédéric

Merci je vais essayer.
Cdlt
Yann