V13 Pb désactivation module [avec module multi-société]

Merci à toute l’équipe de développement dolibarr pour cette nouvelle version.

Je tiens à vous informer que je ne peux pas désactiver aucun module depuis cette mise à jour.

à chaque fois que j’essaie de désactiver un module, j’ai ce message d’erreur :
Le jeton de sécurité a expiré, aussi l’action a été annulée. Merci de ré-essayer.

[MODERATION: message déplacé: la section « annonce » n’est pas destinée à résoudre les pb]

Idem !

De plus, dans Configuration/Sécurité/Divers : impossible d’activer/désactiver.
Dans Configuration/Affichage : Impossible d’activer/désactiver quoique ce soit.

Dans un premier temps, j’ai cru que tout les boutons d’activation ne marchaient pas, mais dans Configuration/Sécurité/Permission : les boutons d’activation fonctionnent.

Et enfin, pour cette première revue, je ne vois pas le module recrutement. Il est présent dans les fichier, ainsi que dans Configuration/Outils d’administration/Infos Dolibarr/Modules/Applications

Merci à ceux qui cherchent.

Core : 
PHP Version	7.2.34
allow_url_fopen	On	On
allow_url_include	Off	Off
arg_separator.input	&	&
arg_separator.output	&	&
auto_append_file	no value	no value
auto_globals_jit	On	On
auto_prepend_file	no value	no value
browscap	no value	no value
default_charset	UTF-8	UTF-8
default_mimetype	text/html	text/html
disable_classes	no value	no value
disable_functions	no value	no value
display_errors	Off	Off
display_startup_errors	Off	Off
doc_root	no value	no value
docref_ext	no value	no value
docref_root	no value	no value
enable_dl	On	On
enable_post_data_reading	On	On
error_append_string	no value	no value
error_log	error_log	error_log
error_prepend_string	no value	no value
error_reporting	22519	-32768
expose_php	On	On
extension_dir	/opt/alt/php72/usr/lib64/php/modules	/opt/alt/php72/usr/lib64/php/modules
file_uploads	On	On
hard_timeout	2	2
highlight.comment	#FF8000	#FF8000
highlight.default	#0000BB	#0000BB
highlight.html	#000000	#000000
highlight.keyword	#007700	#007700
highlight.string	#DD0000	#DD0000
html_errors	On	On
ignore_repeated_errors	Off	Off
ignore_repeated_source	Off	Off
ignore_user_abort	Off	Off
implicit_flush	Off	Off
include_path	/home/verslaterreorg/crm/htdocs	.:/opt/alt/php72/usr/share/pear
input_encoding	no value	no value
internal_encoding	no value	no value
log_errors	Off	Off
log_errors_max_len	1024	1024
mail.add_x_header	Off	Off
mail.force_extra_parameters	no value	no value
mail.log	no value	no value
max_execution_time	1440	1440
max_file_uploads	40	40
max_input_nesting_level	64	64
max_input_time	1440	1440
max_input_vars	1000	1000
memory_limit	5120M	5120M
open_basedir	no value	no value
output_buffering	4096	4096
output_encoding	no value	no value
output_handler	no value	no value
post_max_size	512M	512M
precision	14	14
realpath_cache_size	4096K	4096K
realpath_cache_ttl	120	120
register_argc_argv	Off	Off
report_memleaks	On	On
report_zend_debug	On	On
request_order	no value	no value
sendmail_from	no value	no value
sendmail_path	/usr/sbin/sendmail -t -i	/usr/sbin/sendmail -t -i
serialize_precision	100	100
short_open_tag	On	On
SMTP	localhost	localhost
smtp_port	25	25
sys_temp_dir	no value	no value
track_errors	Off	Off
unserialize_callback_func	no value	no value
upload_max_filesize	512M	512M
upload_tmp_dir	no value	no value
user_dir	no value	no value
user_ini.cache_ttl	300	300
user_ini.filename	.user.ini	.user.ini
variables_order	EGPCS	EGPCS
xmlrpc_error_number	0	0
xmlrpc_errors	Off	Off
zend.assertions	1	1
zend.detect_unicode	On	On
zend.enable_gc	On	On
zend.multibyte	Off	Off
zend.script_encoding	no value	no value
zend.signal_check	Off	Off

Sur une autre occurrence, les boutons fonctionnent.

Quid, toujours du module recrutement.

Core :
PHP Version	7.4.14
allow_url_fopen	On	On
allow_url_include	Off	Off
arg_separator.input	&	&
arg_separator.output	&	&
auto_append_file	no value	no value
auto_globals_jit	On	On
auto_prepend_file	no value	no value
browscap	/usr/lib/php7.4/browscap.ini	/usr/lib/php7.4/browscap.ini
default_charset	UTF-8	UTF-8
default_mimetype	text/html	text/html
disable_classes	no value	no value
disable_functions	no value	no value
display_errors	On	On
display_startup_errors	Off	Off
doc_root	no value	no value
docref_ext	no value	no value
docref_root	no value	no value
enable_dl	On	On
enable_post_data_reading	On	On
error_append_string	no value	no value
error_log	no value	no value
error_prepend_string	no value	no value
error_reporting	22519	22517
expose_php	On	On
extension_dir	/usr/lib/php7.4/extensions	/usr/lib/php7.4/extensions
file_uploads	On	On
hard_timeout	2	2
highlight.comment	#FF8000	#FF8000
highlight.default	#0000BB	#0000BB
highlight.html	#000000	#000000
highlight.keyword	#007700	#007700
highlight.string	#DD0000	#DD0000
html_errors	On	On
ignore_repeated_errors	Off	Off
ignore_repeated_source	Off	Off
ignore_user_abort	Off	Off
implicit_flush	Off	Off
include_path	/kunden/homepages/30/d692085464/htdocs/crmfbach/htdocs	.:/usr/lib/php7.4
input_encoding	no value	no value
internal_encoding	no value	no value
log_errors	Off	Off
log_errors_max_len	1024	1024
mail.add_x_header	Off	Off
mail.force_extra_parameters	no value	no value
mail.log	no value	no value
max_execution_time	50000	50000
max_file_uploads	20	20
max_input_nesting_level	64	64
max_input_time	-1	-1
max_input_vars	5000	5000
memory_limit	-1	-1
open_basedir	no value	no value
output_buffering	0	0
output_encoding	no value	no value
output_handler	no value	no value
post_max_size	64M	64M
precision	14	14
realpath_cache_size	4096K	4096K
realpath_cache_ttl	120	120
register_argc_argv	On	On
report_memleaks	On	On
report_zend_debug	On	On
request_order	no value	no value
sendmail_from	no value	no value
sendmail_path	/usr/sbin/sendmail -t -i	/usr/sbin/sendmail -t -i
serialize_precision	-1	-1
short_open_tag	On	On
SMTP	localhost	localhost
smtp_port	25	25
sys_temp_dir	no value	no value
syslog.facility	LOG_USER	LOG_USER
syslog.filter	no-ctrl	no-ctrl
syslog.ident	php	php
track_errors	Off	Off
unserialize_callback_func	no value	no value
upload_max_filesize	64M	64M
upload_tmp_dir	no value	no value
user_dir	no value	no value
user_ini.cache_ttl	300	300
user_ini.filename	.user.ini	.user.ini
variables_order	EGPCS	EGPCS
xmlrpc_error_number	0	0
xmlrpc_errors	Off	Off
zend.assertions	1	1
zend.detect_unicode	On	On
zend.enable_gc	On	On
zend.exception_ignore_args	Off	Off
zend.multibyte	Off	Off
zend.script_encoding	no value	no value
zend.signal_check	Off	Off

Bonjour

que signifie « Sur une autre occurrence, les boutons fonctionnent. » ?
sur une autre instance ?

pour le module recrutement: il est en expérimental en V13, il faut initialiser la variable MAIN_FEATURES_LEVEL à 1 pour y avoir accès.

@fbach évite de poster 15 fois le même message et la même question sur le forum stp.

vous pouvez fair un test tous les deux ?

passez temporairement la variable $dolibarr_nocsrfcheck à 0 dans conf/conf.php

déconnectez vous - reconnectez vous de dolibarr -> vous avez encore le pb ?

Oui une autre instance.

Nickel pour la variable MAIN_FEATURES_LEVEL

Quel post 15x ?

La variable $dolibarr_nocsrfcheck est déjà à 0 dans conf/conf.php

Je peux confimé ce probleme avec « Security token has expired, so action has been canceled. »
Malheuruesement rien indique de que security token on parle. Mais je peux deja constater: Il a rien a voir avec MAIN_FEATURES_LEVEL ou MAIN_SECURITY_CSRF_WITH_TOKEN
On peut le mettre comme on veux ca change rien sur ce erreur
Je pense l’unique solution ici sera que le developpeur de ce message nous explique qu’il faut faire pour renouveler ce security token. Merci

Bonjour,

Pouvez-vous regarder les valeurs des variables :

  • $dolibarr_nocsrfcheck dans le fichier conf/conf.php ?
  • MAIN_SECURITY_CSRF_WITH_TOKEN dans Configuration-> Autre ?

Vous pouvez essayer de désactiver la sécurité en positionnant ces deux variables à :

  • $dolibarr_nocsrfcheck ⁼ 1
  • MAIN_SECURITY_CSRF_WITH_TOKEN = 0

Je confirme le problème sur 2 installations de dolibarr v13 que $dolibarr_nocsrfcheck soit à 0 ou à 1 dans conf/conf.php, cela ne change rien j’ai toujours le problème « Le jeton de sécurité a expiré, aussi l’action a été annulée. Merci de ré-essayer. »

  • $dolibarr_nocsrfcheck ⁼ 1
  • MAIN_SECURITY_CSRF_WITH_TOKEN = 0
    même problème
  • $dolibarr_nocsrfcheck ⁼ 0
  • MAIN_SECURITY_CSRF_WITH_TOKEN = 0
    même problème
  • $dolibarr_nocsrfcheck ⁼ 1
  • MAIN_SECURITY_CSRF_WITH_TOKEN = 1
    même problème

j’ai ce message uniquement dans la partie activation des modules uniquement dans la partie par exemple divers tout fonctionne.
Important j’utilise multicompany v12.01. Je suis passé en admin dans l’entité maitre et là ça marche . donc je souconne une incompatibilité avec multicompany v12.01 . Les autres conributeurs de ce forum qui rencontre c eproblème ont-ils également ce module installé?

En effet, j’ai aussi le module multi-compagnie sur celui qui est en erreur.

Pas sur le dolibarr qui n’a pas l’erreur.

Pour info, je réinstalle la 12.0.4, dans l’attente d’une solution.

Bonjour,
cela me semble le problème constant de l’adoption de modules externes sur Dolibarr :

  • quand on souhaite adopter la version suivante (majeure) de Dolibarr, il me semble qu’il est nécessaire de mettre en essai une installation hors production afin de faire le bilan des modules externes toujours fonctionnels et de ceux dont il faut solliciter ou attendre une mise à jour avant de basculer en production cette nouvelle version.
1 J'aime

Multicompany touche à la structure des entités. Une nouvelle version de multicompany en vue sans doute. Je vosi avec leur support

pour les autres modules c’est faisable. Pour multicompany, qui modifie la structure en créant des entités sosu dolibarr: ce n’est pas possible, sauf à avoir une autre installation de dolibarr sans multicompany (inutilisable dans la pratique) . Vivement que ce module fasse partie de dolibarr une bonne fois pour toute ( j’espère un jour).

$dolibarr_nocsrfcheck ⁼ 1
MAIN_SECURITY_CSRF_WITH_TOKEN = 0

toujours le problème malgré de paramétrage

Bonjour,

Le problème semble venir du module Multi Company.
Je vous conseil de rester en V12 tant que le développeur du module n’a pas fait les modifications nécessaires.

Un message a été scindé en un nouveau sujet : V13 Pb désactivation module [sans module multi-société]

Solution Provisoire à l’attente de la nouvelle màj :
J’ai remplacé le fichier modules.php sur le dossier admin avec le fichier modules.php de la version 12.0.4 et ça marche