Transfert de Dolibarr sur Synology - erreurs 504 timeout et 403

Bonjour,

Je tente de transférer un instance Dolibarr 10.0.3 jusqu’ici installée sur un serveur distant LEMP Debian 10, vers un Synology DS220+ avec Webstation / Php 7.4 / Apache 2.4

  • Dans le vhost de webstation je fais pointer mon domaine vers le dossier /web/dolibarr

  • Je crée ce dossier /web/dolibarr en décompressant l’archive dolibarr-10.0.3.zip au bon endroit

  • http est en lecture seule sur le dossier

  • Je crée le fichier /web/dolibarr/htdocs/conf/conf.php à partir du fichier exemple et je donne à http les droits en écriture sur ce fichier

  • Dans les paramètres PHP j’ai passé la variable max_execution_time à 1000

  • Je transfère ma sauvegarde de documents dans /web/dolibarr/documents et je donne à http les droits en écriture dessus. Je supprime le .htaccess et le install.lock

  • dans phpmyadmin je crée une bdd dolibarr et je donne les droits à un utilisateur de la bdd pour l’administrer

  • J’importe le dump de ma BDD existante dans cette BDD dolibarr

  • Je me rends sur https://dolibarr.mondomaine.fr/htdocs/install
    Toutes les coches sont vertes et il n’y a qu’un seul choix : « nouvelle installation » que je prends

  • Dans la config je modifie l’url racine : de https://dolibarr.mondomaine.fr/htdocs à https://dolibarr.mondomaine.fr

  • Je rentre les infos de ma bdd (port 3307, identifiant, mot de passe, …)

  • A l’étape suivante step 1, toutes les coches sont vertes, la connexion à la base se fait correctement

  • Je clique sur étape suivante, j’attend, j’entends mes disques durs qui s’agitent

  • j’arrive sur une erreur : 504 Gateway timeout

  • Je reviens en arriere sur mondomaine/htdocs

  • Cette fois il me propose « Mise à jour 9.0.* ou 10.0.0 -> 10.0.* » : je choisis de suivre avec cette option
    et je clique sur « démarrer »

  • Je tombe sur la page « migration de la base de données », pas d’erreur signalée, je continue

  • Migration terminée ! étape suivante

  • Dolibarr a été mis à jour avec succès. Attention, pour des raisons de sécurité, afin de bloquer une nouvelle utilisation des outils d’installation/migration, une fois l’installation terminée, il est conseillé de placer dans le répertoire document de Dolibarr un fichier nommé install.lock en lecture seule.

  • Je clique sur « accès à l’application » : là :
    - si j’ai créé le install.lock en lecture seule dans documents j’ai une erreur comme quoi l’application a tenté de se mettre à jour mais n’a pas pu à cause du install.lock
    - si je ne l’ai pas créé le lien me renvoie sur https://dolibarr.mon domaine/htdocs/install/check.php?testget=ok et on repart à l’étape précédente
    - si je vais directement sur dolibarr.mondomaine.fr j’ai une erreur 403

Je tourne en boucle depuis hier soir avec ça…

Merci de votre aide ! Je dois absolument réussir cette migration…

Edit : j en’utilise pas le paquet pour Synology proposé pour 2 raisons :

  • il est payant
  • je ne pense pas qu’il me permettra de faire tourner plusieurs instances de Dolibarr, or j’en ai 3 à installer.

Je comprend pas il faut faire cela avant l’installation directement chez votre registar

Non rien à voir avec le registrar là, c’est au cours de l’install de dolibarr qu’il me demande quelle est l’url racine.

Chez mon registrar tout est bien en place

Cet écran là :

Mon problème est résolu :

  • Dans webstation il fallait pointer vers web/dolibarr/htdocs et non web/dolibarr
  • Il fallait remplir manuellement le fichier de conf au lieu de laisser l’installation le faire.

Merci à celui qui m’a aidé

1 « J'aime »

@Augustin76 : Bonjour, j’ai le même souci que toi sur le time out et le bouclage sans cesse sur l’install. Comment as tu modifier le fichier conf pour t’en sortir? ( sur 3 nas Synology différents!)