Problème connexion simultanée

Bonjour à tous,

je me permet d’ouvrir ce sujet car je n’ai rien trouvé de similaire dans les sujets.

Je rencontre un petit problème avec mon Dolibarr en V11.0.4
Il est hébergé sur un serveur Dell R240 dont voici les caractéristiques techniques
image

Nous sommes 2 (voir 3 de temps en temps) à utiliser Dolibarr et il est très difficile parfois de s’y connecter simultanément.
Lorsque je me connecte en premier (via l’URL depuis mon PC en attaquant le serveur), tout fonctionne mais lorsque que mon collègue se connecte également, lui n’arrive pas ouvrir le lien depuis son PC. Si j’ouvre une nouvelle page Dolibarr sur mon PC, la situation se débloque pour lui mais lorsqu’il réalise une nouvelle action, l’interface met beaucoup de temps et ne répond plus. Si je ferme Dolibarr de mon côté, cela le débloque sur son PC.

Je n’ai pas le souvenir que j’avais se problème avant lorsque nous étions en V9.

Je ne pense pas que cela soit bien grave à résoudre mais une chose est sur, il est très difficile pour nous d’exploiter Dolibarr en même temps.
J’ai vu dans d’autre sujets que certain sont beaucoup à utiliser Dolibarr en même temps.

Quel serait le problème d’après vous ?
Et quel serai la solution svp ?

Un grand merci par avance.

Bonjour
Vous êtes sous Windows on dirait ? Lequel ?
Quelle est l’installation en place. A la main Apache,php,mysql… ou Doliwamp ?
Utilisez vous des identifiants identiques ?
Y a t il des warning dans les logs du serveur ?
@+

Bonjour,
Je suis sous Windows server 2019 (depuis peu) et avant, l’installation tournait sous Windows server 2008 et le problème était identique.
J’utilise actuellement Doliwamp (pas d’installation à la main).
Les identifiants sont différents, chacun se log sous son propre compte.
Enfin pour les Warning, ils y en a quelques uns mais rien qui a l’air de toucher Dolibarr.

Bonjour,

Ne cherchez plus, Doliwamp n’est pas fait pour du multi utilisateurs.
Penchez vous sur une installation à la main : https://wiki.dolibarr.org/index.php/Installation_manuelle_sous_Windows

Un win server pour 3 personnes ?
Il va pas surcharger :upside_down_face:

J’ai mentionné le fait que nous sommes 2 voir 3 à utiliser Dolibarr, mais le serveur sert également à beaucoup d’autre chose dans la société, pas qu’a Dolibarr :wink:

Merci pour la réponse, bon ben je n’ai plus qu’a faire une bonne sauvegarde et procéder à l’installation manuellement.

Tu tiens ça d’où ? Autant la version de php et les performances ne sont pas top autant rien n’empêche le multi utilisateur ?
Bon maintenant Doliwamp sur un Window$ 2019 64 bits c’est un peu bricolage.
@+

Salut,

Il n’y a pas d’impossibilité techniques, c’est juste qu’il n’a pas été pensé pour ça et de toute façon Doliwamp dés que tu as plus d’un seul utilisateur les performances ne sont pas au rendez-vous (et tu en a encore la preuve aujourd’hui).

Doliwamp c’est uniquement pour tester Dolibarr ou pour un micro entrepreneur/TPE avec un seul utilisateur.

Je pense qu’il ne faut pas avoir peur de le dire, ce n’est pas un gros mot !
Doliwamp est très limité et sert de produit d’appel mais dés que l’on veut en faire un outil central de sont entreprise, il faut oublier !

Je n’ai pas peur, j’aime juste la précision. Cela dit quand va t’on revoir cet installateur !
@+

Slt
il faut pas le « revoir ».Il faut l abandonner purement et simplement !
Cet installateur n a aucun interet…

Il y a assez d explications pour installler doli+ apache+ sql facilement
Passer du temps sur cet installeur n a aucun interet pour gagner 3 clics a l install
et etre emmerdé avec le mdp root/a la 1ere MAj/en double install…

Il serait bien plus utile de finir certaines fonctions ds dolibarr
(Ex:PDF produit ou PDF adherent )

Dolimamp est mort
vivement que ses 2 freres le soient aussi
https://www.aplose.fr/blog/2017/04/13/pourquoi-il-ne-faut-pas-installer-dolibarr-sur-son-pc-windows/

Moi j’aime bien le concept DoliWamp pour les néophytes. La majorité est sur Windows.
Ça rend l’installation ultra simple même si je préfère l’installation manuelle bien sûr !
Dommage que php soit en version 5 :frowning:

Sinon je ne vois aucun argument à part orienter les utilisateurs vers des hébergements encore et toujours. Linux pour un néophyte j’en parle même pas. Si on veut rendre accessible Dolibarr il faut pouvoir déployer en un clic sur Window$ voir sur Mac.
@+

1 J'aime

Salut,

J’ai demandé les sources pour le faire évoluer mais sans succès…

1 J'aime

Tout d’abord merci à tous pour votre implication.
Je ne maîtrise vraiment pas cette partie et j’étais très loin de me douter que d’installer dolibarr via Doliwamp pouvais générer tant de problème par la suite. Certaines choses m’échappe encore, pourquoi se compliquer la vie à devoir installer apache, SQL et Dolibarr manuellement alors qu’un installateur pourrai le faire. Enfin je dis ça car pour un utilisateur lambda comme moi qui n’a pas connaissance de tout ça, c’est compliqué de deviner la différence entre une installation manuelle et automatique.
En tout cas je comprends un peu mieux le fonctionnement de Doli et je vous en remercie.

Bonjour,

En effet, tout ça est bien compliqué mais dans votre cas, le mieux est de passer par votre installateur de serveur car j’imagine que vous n’avez pas installé un serveur 2019 tout seul n’est ce pas ?
En tout cas chez moi tout fonctionne très bien avec un serveur nas + apache pour 6 utilisateurs et des milliers de fichiers très lourds ( imprimerie )

Agréable journée

Bonjour,

lors de l’installation du service Apache, j’obtiens ce message d’erreur

J’ai changé le port 80 (déja utilisé) par le 81 mais le problème est identique.

merci pour votre aide

J’ai préparé et installé le serveur moi-même si.
Le problème est que je ne maitrise pas toute la partie base de données.
pour le reste, en terme de paramétrage réseau et environnement Windows je me débrouille mais dès qu’il y a paramétrage de base de données, ça se complique pour moi.
Bon la j’ai pu résoudre mon problème avec apache2.4, je n’ai plus d’erreur de synthaxe et j’ai également résolu mon problème de port déjà pris. L’installation du service Apache se déroule correctement sans erreur, cependant le service ne veut pas démarrer et me retourne une erreur que je n’arrive pas à résoudre.

Oui enfin il faudrait s’intéresser au message d’erreur de la capture d’écran avant de modifier le port.
Le « ServerName » n’a pas été déclaré ; avez-vous redémarré la bestiole ?
D’ailleurs, je me faisait la remarque que c’était dommage de ne pas avoir virtualisé vue les capacités de la bête… mais vous avez certainement des contraintes qui m’échappent.
Si vous tenez à rester sous win 2019 server, pourquoi ne pas utiliser Hyper-V ? (licences, … ?)

Merci pour votre retour.
C’est tout bon, j’ai simplement désinstallé Apache en totalité, redémarré ma machine et réinstallé Apache.A la suite de cela, tout s’est bien passé et j’ai pu restaurer ma base de données à l’aide du gestionnaire HeidiSQL.
Mon Dolibarr est à présent restauré.

Pour répondre à certaines interrogations, je ne suis pas Ingénieur réseau comme certain dans le forum et je ne maîtrise pas tout loin de là. En revanche, je sais m’adapter à l’environnement Windows et grace à mes connaissances j’arrive toujours à m’en sortir. En l’occurrence, ce n’ai pas mon activité principal (heureusement je pense) et si il y a des évidences pour certains d’entre vous, ce n’est pas forcément un réflexe chez moi. j’essaie juste de faire au mieux avec ce dont je connais.
Pour Hyper-V, en effet ça n’a pas été un réflexe car il a fallu préparer en ‹  › urgence ‹  › le nouveau serveur, l’ancien étant un Win$ 2008 prêt à rendre l’âme.
Je n’ai pas donc pas anticipé tout ça.

En tout cas je tiens à remercier ceux tout le monde sur ce sujet.

Cordialement

1 J'aime