Nouveautes Dolibarr v8

Bonjour Chers tous,
quelqu’un pourrait il me donner une idée des principales nouveautés de la version 8?
Merci d’avance

Bonjour,
beaucoup de correction et le nouveau modul TICKET

voice le changelog:
https://raw.githubusercontent.com/Dolibarr/dolibarr/8.0.0/ChangeLog

1 J'aime

Et un grand merci de nous sortir une nouvelle Version en plein mois d’aout, sans prévenir une fois de plus…
Je me lance dans la validation de mes modules…

J’ai installé la v8 mais je ne trouve pas ce module ticket. Il est sensé etre disponible en version de base ou s’agit il du module payant développé par AXeL dev?

Bonjour Slonecznamartynika
il faut activer le mode developpeur

Mode développeur?? comment on active ca?

Bonjour,

Pour cela : Accueil > Configuration > Divers, puis modifier la valeur de « MAIN_FEATURES_LEVEL » à 2

:wink:

1 J'aime

Bonjour Defrance,

En voulant installer votre nouvelle version 1.9.0 de Factory
j’ai la notification : Incorrect string value: ‹ \xE0 jour… › for column ‹ libelle › at row 1
impossible d’activer et d’utiliser le module Factory dorénavant.

Une idée de correction ?

Informations techniques Valeur
Version de Dolibarr 8.0.0
Version du module 7.0.+1.8.4 (2018-06) ===> 1.9.0 ???
Version de PHP 7.0.30
Version de la base de données MySQL or MariaDB 5.7.21-log
Version du serveur web Apache

D’avance merci,

Bonjour,

Il s’agit du module ticket sup développé par https://librethic.io qui était payant et vient de passé dans le core en version développement, donc avec activation nécessaire des modules en developpement.

J’utilise ce module depuis plusieurs années : la version V8 est très proche de l’ancienne version : elle a été modifiée pour s’intégrer au core mais propose les mêmes fonctionnalités : c’est absolument génial pour gérer des questions clients.

Elle présente cependant les mêmes anomalies : on a beau ouvrir tous les droits à un utilisateur de dolibarr, il a accès à la liste des ticket de tous les clients mais pas au contenu du ticket, seulement pour ceux dont il est le commercial. : il faudrait pouvoir améliorer la gestion des droits.

Autre soucis rencontrés : le nouveau module ne reprend pas la base des aciens tickets : il faut donc faire une petite migration de base de donnée « à la main » afin de pouvoir désactivé l’ancien module : j’ai pas encore fait donc pas encore désactivé…

Mais encore merci au développeur surtout de l’avoir intégré dans le core : quand c’est possible, c’est quand même le top pour les mise à jour coté utilisateur ! et cela fait faire de grand pas en avant à Dolibarr !

Cdt

fxc

Merci d’ouvrir un autre fil de discussion, c’est un problème d’encodage de base qui ne doit pas être en unicode

Fred

Dans les nouveauté de la V8, il y a une modification du nom des modèles de documents
par exemple avant la 1.8 les documents s’appelaient modeleEquipement et maintenant modèlePDFEquipement
cela semble simple mais oblige de faire une surclasse pour assurer la rétro-compatibilité avec les anciennes versions dolibarr…

1 J'aime

Vous voulez dire que vous travaillez à cette correction dans une nouvelle version du module Equipement, et qu’il n’y a rien à faire du côté utilisateur ?

Est-ce bien cela ?

Merci de votre confirmation,