Mon menu ne s'affiche pas

Salut à tous.

J’ai suivi à la lettre la documentation wiki de création d’un module et je n’arrive pas à afficher mon module dans le top menu.

Mon module est bien visible dans la config (je peux l’activer dans la configuration), mais il ne s’affiche pas en haut.

Voici le code que j’ai mis pour top menu dans htdocs/StatistiquesCLP/core/modules/modStatistiquesCLP.class.php

// Main menu entries
$this->menu = array(); // List of menus to add
$r=0;

	// Add here entries to declare new menus
	//
	// Example to declare a new Top Menu entry and its Left menu entry:
	 $this-\>menu[$r]=array(	'fk_menu'=\>0,			                // Put 0 if this is a top menu
								'type'=\>'top',			                // This is a Top menu entry
								'titre'=\>'Statistiques CLP',
								'mainmenu'=\>'Statistiques CLP',
								'leftmenu'=\>'Statistiques CLP',
								'url'=\>'/StatistiquesCLP/general.php',
								'langs'=\>'[email protected]',	        // Lang file to use (without .lang) by module. File must be in langs/code_CODE/ directory.
								'position'=\>100,
								'enabled'=\>'$conf-\>mymodule-\>enabled',	// Define condition to show or hide menu entry. Use '$conf-\>mymodule-\>enabled' if entry must be visible if module is enabled.
								'perms'=\>'1',			                // Use 'perms'=\>'$user-\>rights-\>mymodule-\>level1-\>level2' if you want your menu with a permission rules
								'target'=\>'',
								'user'=\>2);				                // 0=Menu for internal users, 1=external users, 2=both
	$r++;
	//

Merci pour votre aide.

hello
je pense que c’est là où cela déconne :

‹ enabled ›=>’$conf->mymodule->enabled’,

il faut juste mettre :
‹ enabled ›=>1,

et cela devrait suffire