Module Stripe : boucle de redirection

Bonjour,

Je viens d’installer un Dolibarr 10.0.1 pour tester le nouveau mécanisme de paiement SCA de Stripe.

J’ai activé le module Stripe, les modules Tiers, Facturation, Banque (nécessaires ?)

J’ai configuré les clefs et les webhooks, activé le Payement Intent comme indiqué dans le wiki : https://wiki.dolibarr.org/index.php/Module_Stripe_FR

En testant avec une facture et un tiers, la page s’affiche bien (URL /public/payment/newpayment.php?source=invoice&ref=FA1908-0001 )

Mais avec un montant libre, j’ai une boucle de redirection : (URL : /public/stripe/newpayment.php?amount=60.00000000&tag=FA1909-0101&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe&paymentmethod=stripe )

Ça me fait pareil sans le paramètre Payment Intent, et avec le module de Dons activé aussi.

Est-ce que le comportement est « normal » ? Cela fonctionne bien sur un autre Dolibarr en version 7, là sur une 10.0.1 fraîchement installée, ça veut pas.

Est-ce que je devrais vous passer l’URL de l’instance pour vérifier ?

EDIT : je suis un imbécile, la bonne adresse pour les paiements c’est /public/payment/newpayment.php?amount=60.00000000&tag=FA1909-0101 et non pas /public/stripe/newpayment.php?amount=60.00000000&tag=FA1909-0101 :blush:

Bref, ça marche.

3 J'aimes