Mise à jour de 3.8.3 à 8.1

Bonjour,

J’envisage de mettre à jour Dolibarr avec sa dernière version, mais cela ne semble pas simple avec une version trop ancienne (ce qui est un peu normal, j’aurais dû le faire plus tôt).

je pense que la meilleur façon est d’installer la dernière version de Dolibarr et d’y importer mes données de l’ancienne version (contact, projets, devis, facture)… cela est-il possible ?
Pour infos, je n’utilise pas la partie comptabilité du logiciel

Ou bien faut-il faire d’une façon totalement différente ?

Merci d’avance pour vos conseils.
Didier

Bjr

Quel systeme utilisez vous ?
Hebergeur ou localhost ?

Bonjour :happy:

Je te conseille :

  1. sauvegarde de ton dolibarr complet :evil:
  2. mise a jour de la 3 vers la 4, 4 vers 5 etc

Bonjour,

On peut mettre à jour votre installation depuis les branche 3.XX. C’est un peu long mais ça se fait sans soucis (compter 4h entre mise a jour et nettoyage des fichiers, paramètrages complèmentaires…) sous réserve de connaitre les petites astuces et quelques précautions.

J’utilise dolibarr sur un serveur distant pas en localhost

ok alors d abord une sauvegarde de la base
et copie ftp de votre dossier dolibarr
Export en phpadmin …voir doc de votre hebergeur :wink:

Bonjour,

avez-vous voulu dire quelque chose comme « 8.0.1 » ou encore « 8.0.2 » ? En lisant, j’ai cru qu’une « new-new-new » version était sortie. :happy:
Et j’ai été voir sur le dépôt Sourceforge…

Pour être plus précis,avec les recommandations de sauvegarde, au niveau des fichiers, on met en place directement la 8.0.2, puis, au démarrage, il va être proposé de passer par toutes les montées de version, ce qu’il faudra faire.

Peux-tu être moins mystérieux ?

1 J'aime

Merci pour vos réponses
@yves57

Peux tu est plus précis avec ce point … que veux tu dire exactement .

  1. - Je place les fichiers dezippés de la 8.0.2 dans le dossier htdocs ?
  2. - si oui à la place de ceux existants ?
  3. - j’ai ajouter des composants externes via le dolistores, ils risquent de poser des problèmes ?

Oui écraser les fichiers htdocs existants:

Les modules risquent de ne plus fonctionner ou de rencontrer des erreurs à voir avec leurs éditeurs

Il faut en effet sauvegarder la base et s’etre assurer de la bonne organsiation des dossiers: documents en dehors de htdocs et les plugins supplementaire dans le dossier custom. La mise a jour sera bien à faire pas à pas version par version.

Vu la version de depart , il va y avoir de nombreuses erreurs lors de mises a jour et ecran et il faudra purger ensuite les fichiers inutiles. Parfois il faut aussi corriger à la main la base de données pour certaines variables (cas chez mon dernier client)

ensuite mettre a jour les plugins supplémentaires, reparametrer les modules parce que depuis la 3.8 il y a eu beaucoup de changement et d’ajout…

Ca prend bien 4h pour faire ça proprement et de manière sur. Toujours faire un audit de la situation avant de se lancer.

bonjour
je me permet de rentre dans cette discutions que je la trouve très proche de mon problème
j’ai la version 3.2.2 et J’envisage de mettre à jour avec la dernière version, Dolibarr est installer sur un serveur local sous windows
pourriez vous m’expliquer les étapes a suivre
merci d’avance

Bonjour,

Vous voulez l’installer ou le nouveau Dolibarr ?

PS : Il vaut mieux créer votre propre sujet.

Bonjour en effet vous placez les fichiers dans le htdocs mais personnellement j’irais par étape de version majeures. Je m’explique, je ferais

  1. Aller à la version 4
  2. Aller à la version 5
  3. Aller à la version …
  4. Aller à la version 8

Cela limitera le nombre de fichier impactés et facilitera le retour à l’ancienne version au besoin.

Pour vos autres modules, oui il y’a eu des changements mais normalement le développeur a du respecter une certaine structure et cela devrait toujours fonctionner. Si pas prévenez nous.

Dans tous les cas faites bien une sauvegarde des fichiers avant ;-). Vérifiez aussi que personne n’utilise la plateforme quand vous êtes occupé à faire les migrations :D.

Dans l’espoir d’avoir pu vous aider

Bonjour tout le monde,

J’ai un petit soucis pour la mise a jour a la version 8,
je suis en version 6.0.4 lorsque j’écrase mon dossier par la version 7 je n’ai pas l’option de mise a jour vers la version 7.
je ne peux que mettre à jour en 6 ?
Quelqu’un a une solution ?
Merci.

Capturedcran2018-12-0223.37.48.png

Bonjour tout le monde,

J’ai un petit soucis pour la mise a jour a la version 8,
je suis en version 6.0.4 lorsque j’écrase mon dossier par la version 7 je n’ai pas l’option de mise a jour vers la version 7.
je ne peux que mettre à jour en 6 ?
Quelqu’un a une solution ?
Merci.

Capturedcran2018-12-0223.37.48.png

Bonjour,

Vous pouvez poussez directement la version 8.0.3 sans soucis, les mises à jour intermédiaires seront proposées.
Vous avez certainement du poser les fichiers au mauvais endroit. Pour en être sûr, vider votre dossier htdocs (ou sont équivalent) sans supprimer les dossiers conf et custom. Ensuite poussez votre version 8 et lancer votre Dolibarr.

Attention avant toutes tentatives, faites une sauvegarde de votre base de données et de votre dossier documents.
Mieux : faites un essai sur une version de test.

@+

MERCI pour votre réponse
avant de commencer j’aimerai vous expliquer les étapes que je veux les lancer
j’ai un nouveau serveur sous windows avec la version 8.1 installer, et je veut importer m en ancienne base de donner de 3.8.3
quel son les étapes a suivre ?
merci d’avance

Salut ADLENE,

il faut faire le contraire :
- installer la même version de dolibarr sur le nouveau serveur (3.8.3)
- migrer les données sur le nouveau serveur (3.8.3)
- mettre à jour le nouveau serveur (3.8.3 -> 8x)

Toutes les infos sur le wiki :
https://wiki.dolibarr.org/index.php/Documentation_utilisateur#Installation.2FD.C3.A9marrage.2FMise_.C3.A0_jour

1 J'aime

Salut Arnaud,
Qu’est ce qui te fais dire que ma méthode n’est pas la bonne ?
Tu installes ta 8.0.3, tu restaure ta base 3.8 dessus et ensuite tu lances les assistants de migration sans soucis.
J’en fais une à deux par semaine sans problème. Quand ça coince, c’est une coquille dans la base et non un soucis de méthode.
@+