Liste déroulante vide ou inexistante

Bonjour,

Après une migration de la 6.0.1 vers la 9.0.0 je constate cette erreur :

- les export enregistrés n’existent plus : Outil-- >Nouvel export — > Factures clients et ligne de facture La tu peux sélectionner les champs ou "Choisissez les champs à exporter, ou choisissez un profil d’export prédéfini " Il n’y a plus d’export prédéfini .

- Le choix du module Alpiroc n’est plus possible

Quelqu’un peux m’aider stp

Merci

Pièces jointes :

Bonjour,

Pour le module alpiroc, il est fort possible qu’il ne soit plus compatible. Avez-vous essayé de le désactiver/activer ?

Frédéric

Bonjour

Oui mais cela ne se produit pas que sur le module alpiroc, j’ai des exports préenregistrés et je ne peux pas les sélectionner dans la liste déroulante

Merci d’avance

Salut doli26,

il faut refaire tes exports personnalisés: je suppose qu’il y a incompatibilité des enregistrements entre tes 2 versions.

Comme te l’a suggéré amipc07: tu as vérifié si ce module était compatible avec une V9 ? (en tout cas, pas de trace de « Alpiroc » dans le dolistore)
Au pire, contact le développeur.

Bonjour

Alpiroc est un détail quand je recrée un export style de facture client si je le renomme de la meme façon il me dis qu’il existe deja
et la liste est vide

Merci

Bonjour,

Non ce n’est pas qu’un détail, le code du module est surement exécuté et peux perturber Dolibarr.
Commencez pas le supprimer.

Bonsoir

Le Module Alpiroc est supprimé et j’ai toujours ma liste déroulante vide

Ne serais ce plutôt pas un probleme PHP ou Ajax

Merci d’avance

Bonjour
Avant de supprimer il a été désactivé ?
@+

Bonjour,

L’as-tu toujours dans la liste des modules ?

Frédéric

Bonjour

Il n’est plus dans la liste des modules

Merci

Bonjour,

Ok. Est-il présent dans l’arborescence du répertoire Dolibarr, c’est à dire sous htdocs ?

EDIT : dans le fichier alpiroc.pdf dans le dossier ‹ document › de l’archive Alpiroc, il est spécifié que la version de Dolibarr validé est la … 3.8.2!!!

Frédéric

Je viens de tester sur une 9.0.3, et le module fonctionne.

Bonsoir

Merci de votre réponse je dois avoir un souci PHP

Bonne soirée

Bonjour,
J’ai un client qui utilise ce module.
On a migré vers le 9.0.3 de Dolibarr et la 7.1.29 de PHP.
Suite à cette migration , plusieurs warning sont apparu et les champs supplémentaires de Alpiroc ne fonctionnaient plus.
J’ai corrigé le code PHP afin de faire disparaître ces warnings mais pour refaire fonctionner les champs supplémentaires, il a fallu :
- aller dans « Configuration » / « Modules/Applications »
- entrer dans la configuration du module « Propositions commerciales »
- Dans l’onglet « Attributs supplémentaires » entrer dans la modification du champ alpiroc et enregistrer sans rien changer.
- Pareil pour les « Attribut supplémentaire (ligne) »

Idem pour les factures, et cela a corrigé le problème.

Si ça peut aider quelqu’un … :wink:

Bonne journée.