Lignes de factures à ventiler

Bonjour,

Comme tous les mois je suis allez sur lignes à ventilé mais suite à la mise à jour vers la v10.0.1 dans la colonne « Code comptable suggéré » je vois un message en jaune « Défaut pour les produits : 701000 Ce produit : Non défini » et je dois à la main me taper 250 lignes dans la colonne « Lier ligne avec le compte comptable ». Avant la màj la colonne « Lier ligne avec le compte comptable » se preremplissait toute seule.

Y a-t-il une solution ? J’ai oublié à nouveau un truck ?

Un autre problème maintenant si je cré un nouveau produit un compte comptable s’affecte automatiquement, sauf là c’est le 706 (services) en non comme renseigné dans les comptes par défaut 701.

Merci.

Bonjour,

Bizarre, bizarre, sur la v10 arrive la gestion des ventes intracomm en compta mais on ne touche pas aux comptes d’origine.

Il semble que vous ayez perdu la configuration des comptes comptables France dans les fiches catalogue (Produits / Services).

Je vous conseille de vérifier l’affectation des comptes comptables en allant dans Comptabilité > configuration > Comptes produits et vérifier si vous n’avez rien en attente d’affectation.

Il faudra aussi vérifier les options d’export car les modèles d’export ont été renuméroté, vous avez possiblement perdu l’information.

Après pour le 706, c’est dans les comptes par défaut, il suffit de mettre 701 sur la ligne service.

Bonne journée,

Bonjour et merci pour votre retour.

Pour vérifier ça, j’ai installé une v10 vierge dans une vm, j’ai fais la config de la compta, 2,3 factures et le problème est identique. la colonne "Lier avec le compte comptable " est vierge et attend d’être renseignée à la main ligne par ligne. Très embêtant.
ci-joint les captures :

lignesdb.png

cpddb.png

cpdb.png
.

Attention lors de la création de mes produits et services on ne précise pas de compte comptable. Dolibarr choisit le bon compte selon si c’est un produit ou un service
.
Maintenant lors de la création de produit et de sévices dans la v10 le compte est automatiquement renseigné et c’est toujours celui des comptes par défaut « Compte comptable par défaut pour les services vendus (utilisé si non défini dans la fiche service) » pour produits et services. Donc ça sera faut pour l’un ou pour l’autre si on ne panse pas à modifier le compte lors de la création de l’article.

Re,

Bon, comme je le disais, il faut affecter vos comptes (Voir la dernière image que vous avez postée), il suffit de cocher à droite et de valider… Ça devrait corriger votre problème.

Après, en niveau Jaune, oui il semble y avoir un problème, il devrait reprendre les comptes par défaut et les suggérer.

Je vais voir ça.

1 J'aime

Merci ça c’est cool !

Et comment ça se passe pour les produits et les services en saisie libre ?

juste encore :

Maintenant lors de la création de produit et de sévices dans la v10 le compte est automatiquement renseigné et c’est toujours celui des comptes par défaut « Compte comptable par défaut pour les services vendus (utilisé si non défini dans la fiche service) » pour produits et services. Donc ça sera faut pour l’un ou pour l’autre si on ne panse pas à modifier le compte lors de la création de l’article.

Un petit up pour :

Et comment ça se passe pour les produits et les services en saisie libre ?

Merci.

Hello,

Pour les produits en saisie libre, c’est le compte par défaut qui est suggéré en fonction du type de ligne => produit ou service.

Bonne journée

Bonjour, dans la v10 ça ne fonctionne pas, pour chaque ligne en libre il faut sélectionner manuellement le compte dans le menu déroulant.

Merci.

Salut vlk,

je confirme : le compte suggéré pour les saisies libres apparaît bien, mais n’est pas sélectionné dans la liste déroulante automatiquement. (10.0.2)

Capture_2019-09-14.png

Hello,

Oui comme expliqué plus au dessus, c’est un bug mais il faut me laisser le temps de le corriger aussi :tongue:

Il va falloir attendre la 10.0.3 :woohoo:

oups, désolé Alexandre, j’avais pas vu ton post d’avant :happy:

ok, c’est noté. merci.

Bonjour,

Le souci n’est pas corrigé en 10.0.3

Bonjour Alexandre,
Effectivement ça n’a pas l’air d’être corrigé dans la 10.0.3.
Vous pouvez confirmer ?

Merci.

Bonjour,

Je confirme que c’est un problème dû à la branche 10 (et 11) et que Laurent avait retravaillé suite à l’ajout par mes soins des notions intra/export sur les ventes sauf que le taf’ n’a pas été jusqu’au bout et que c’est aujourd’hui handicapant.

Voici le correctif que je viens de proposer, sur github

Soit vous corrigez manuellement le fichier, soit il faudra attendre la v10.0.4 dans environ 1 à 2 mois…

Il faudra aussi activer la constante suivante : ACCOUNTANCY_AUTOFILL_ACCOUNT_WITH_GENERIC à 1

Désolé pour ce désagrément, je ne m’en étais pas rendu compte avant.

c’est noté, merci.

Bonjour, il y a encore un bug à la création d’article ou de service. Le compte proposé ne varie pas selon service ou produit.

cdt.