Installation impossible - Erreur SQL.

Bonjour / Bonsoir.

Il m’est actuellement impossible d’installer Dolibarr sur un serveur web. hébergé chez Ovh.
L’installation bloque à l’étape une, après avoir correctement inséré les identifiants de la bdd.

Voici le message que j’obtiens :

Enregistrement du fichier de configuration …/conf/conf.php Ok
Rechargement des informations depuis le fichier de configuration. Ok
Échec de la création de la base ‹ XXXXXXXXXXXX ›.
Si la base existe déjà, revenez en arrière et désactiver l’option « Créer la base de données ».

La bdd a été créée uniquement pour l’installation de dolibarr, elle est donc vierge est accessible via phpmyadmin.
Si quelqu’un a une idée, car sur le web je ne l’ai pas trouvé.

Merci !

Bonjour :happy:
Il te manque sans doute l’utilisateur et ses droits

OK, je viens de débloquer le schmilblick…
Comment je ne sais pas, puisque j’ai inséré exactement les mes informations…

Enfin bon c’est un open source on va pas trop en demander :whistle:

Bonjour
OpenSource ne veut pas dire instable ou mal terminé, ne mélanger pas tout ! :huh:
L’installation fonctionne parfaitement, j’en fais suffisamment pour le certifier.
Il y a certainement quelque chose de différent lors de votre installation. :whistle:
@+

Bonjour,

J’ai le même problème :

comme ceci :
J’ai tout uploadé sur un hébergement OVH.
Je peux accéder à ma base crée via phpmyadmin.
Je renseigne le bon nom de la base, le bon identifiant et le bon mot de passe. (ils fonctionnent avec phpmyadmin)
Je n’indique pas de port.
J’obtiens ceci :
Enregistrement du fichier de configuration …/conf/conf.php OK
Rechargement des paramètres depuis le fichier de configuration. OK
Connexion au serveur (Utilisateur XXX) : localhost OK
Connexion à la base (Utilisateur XXX) : XXX ERREUR
Vérifiez que le nom de base « XXX » est correct.
Si ce nom est correct et que cette base n’existe pas déjà, vous devez cocher l’option « Créer la base de données ».
Revenez en arrière et vérifiez / corrigez les paramètres.

si je garde les mêmes infos et que je laisse le port 3306, j’obtiens ceci :
La connexion à la base de données a échoué: les paramètres de l’hôte ou du super utilisateur doivent être erronés.

comme ceci :
nom de la base : dolibarr
port : rien
je coche la case créer la base de donnée
identifiant : j’en crée un nouveau
mot de passe : j’en crée un nouveau
créer le propriétaire : je ne coche pas
accès superutilisateur identifiant : le nom d’utilisateur OVH (est-ce bien ce qu’il faut renseigner?)
accès superutilisateur mot de passe : le mot de passe OVH (est-ce bien ce qu’il faut renseigner?)
j’obtiens ceci :
Enregistrement du fichier de configuration *…/conf/conf.php* OK
Rechargement des paramètres depuis le fichier de configuration. OK
Échec de la création de la base ‹ dolibarr ›.
Pas plus d’infos

Si je coche la case créer la base de donnée et aussi la case créer le propriétaire ou lui affecter les droits à la base, j’obtiens ceci :
Enregistrement du fichier de configuration *…/conf/conf.php* OK
Rechargement des paramètres depuis le fichier de configuration. OK
Utilisateur de création : XXX Erreur:0
Échec de la création de la base ‹ dolibarr ›.

Qu’est ce que je fais de travers?

Salut pepito8012,

quel est le type d’hébergement chez OVH ?

si c’est du mutualisé, le serveur de bdd n’est pas localhost (regarde ton pannel pour l’avoir)
le port est bien 3306 (sauf si c’est pas du mutualisé et que tu l’as changé)
tous les chemins sont a indiquer en absolu et pas en relatif (regarde ton panel pour les avoir si c’est du mutualisé… si c’est du VPS ou du dédié … tu dois les connaitre)

Bonjour,

C’est un hébergement cloud web plateforme isolée.

pour l’adresse serveur j’ai ceci : nomdelabase.mysql.db
pour le port, je n’ai rien changé donc c’est probablement 3306
pour les chemins, j’indique /home/XXX/www/erp, c’est ce que m’indique OVH et Dolibarr semble les reconnaitre.

Si j’introduis ces données, cela donne :
Access denied for user ‹ XXX ›@‹ 172.20.0.1 › (using password: YES)
La connexion à la base de données a échoué: les paramètres de l’hôte ou du super utilisateur doivent être erronés.

si je laisse le port vide, j’obtiens plutôt :
Enregistrement du fichier de configuration …/conf/conf.php OK
Rechargement des paramètres depuis le fichier de configuration. OK
Connexion au serveur (Utilisateur XXX) : localhost OK
Connexion à la base (Utilisateur XXX) : XXX ERREUR
Vérifiez que le nom de base « XXX » est correct.

tu as créé la BDD ? (à la main)
ou
tu as renseigné les paramètres correctes pour que la procédure puisse créer la bdd ?

(les 2 solutions fonctionnent, à condition de renseigner les login/pass d’un user qui à les bons privilèges pour la 2eme solution)

Hello,

Ça a fini par fonctionner.

J’avais du faire une fausse manip!

Merci pour les infos.