Installation dolibarr 19.0.2 synology DSM 7.2.1 update 5 erreur 504

je tourne en rond depuis hier sur l’installation de Dolibarr sur mon synology DS218:
j’arrive jusqu’au script d’installation, mais je boucle sur l’erreur 504 malgré les tutos divers et variés que j’ai pu lire:
plantage à l’installation avec erreur 504:
https://dolibarr/install/step2.php

DSM 7.2.1-69057 Update 5
Gninx installé de base
Install Text Editor
Install Webstation. (ok, tout est au vert)
install Mariadb. (tourne, port 3306 ok)
Install phpMyAdmin. (tourne ok)
Install PHP 8.1 (install ok)

[CREATION D’UN USER AVEC PHPMYADMIN…
Host is Local
Authentication is Native MySQL
Tick check box for database with same name
(j’ai pas fait ça )Tick check box for global privileges

[INSTALLATION DES FICHIERS DOLIBARR 19.0.2 DANS /web/dolibarr. 1]
droits écriture ok
dossier documents ok

[Puis configuration des services avec webstation : 2]
service web crée, php 8.1
serveur web nginx

[Lancement de l’installation : 2])
[Quand je clique sur démarrer : 3]
tout est au vert,

et je boucle après:

[solution essayées : 4]
timeout nginx augmenté selon les tickets du forum
plusieurs autres inclu desinstallation des package et reinstallation propre, essai d’installation avec dolibarr 19.0.0…
j’ai un superbe pdf avec plein d’images écran de l’installation …

merci pour votre aide !

hello,
peux-tu vérifier si par hasard ton mariad db est bien en 3306 (normalement c’est le 3307)

merci pour ta réponse,
quand je lance le package mariadb c’est bien le port 3306 avec option tcp ip activé
information confirmée dans le panneau de config / centre d’info (port local 3306)

pas de pare-feu/firewall installé, le nas est sur le réseau local derrière le routeur de ma box internet

dans le webstation, le serveur principal est nginx avec php 7.4 (le parametre du langage script PHP est lui configuré sur php 8.1)

normalement à l’étape ou tu en es, tu dois avoir un fichier conf.php qui contient les infos pour te connecter à ta base
peux-tu vérifier son contenue? autre chose, vérifier qu’il soit bien modifiable par l’utilisateur http de synology

un truc qui vaut ce qu’il vaut, utilise 127.0.0.1 au lieu de localhost pour l’accès à la base de données (c’est un poil plus rapide)

détail du fichier php:

$dolibarr_main_url_root=‹ https://dolibarr ›;
$dolibarr_main_document_root=‹ /volume1/web/dolibarr/htdocs ›;
$dolibarr_main_url_root_alt=‹ /custom ›;
$dolibarr_main_document_root_alt=‹ /volume1/web/dolibarr/htdocs/custom ›;
$dolibarr_main_data_root=‹ /volume1/web/dolibarr/documents ›;
$dolibarr_main_db_host=‹ localhost ›;
$dolibarr_main_db_port=‹ 3306 ›;
$dolibarr_main_db_name=‹ dolibarr ›;
$dolibarr_main_db_prefix=‹ llx_ ›;
$dolibarr_main_db_user=‹ dolibarr ›;
$dolibarr_main_db_pass=‹ motdepasse ›;
$dolibarr_main_db_type=‹ mysqli ›;
$dolibarr_main_db_character_set=‹ utf8 ›;
$dolibarr_main_db_collation=‹ utf8_unicode_ci ›;
// Authentication settings
$dolibarr_main_authentication=‹ dolibarr ›;

$dolibarr_main_prod=‹ 0 ›;
$dolibarr_main_force_https=‹ 1 ›;
$dolibarr_main_restrict_os_commands=‹ mariadb-dump, mariadb, mysqldump, mysql, pg_dump, pgrestore, clamdscan, clamscan.exe ›;
$dolibarr_nocsrfcheck=‹ 0 ›;
$dolibarr_main_instance_unique_id=‹ b5f8dc2d56ad6aca862d36c0490a3dc5 ›;
$dolibarr_mailing_limit_sendbyweb=‹ 0 ›;
$dolibarr_mailing_limit_sendbycli=‹ 0 ›;

==> je pense qu’il y a tout…

le groupe http c’est ça?


je pense que c’est ok, non?

j’avais essayé dans une install le 127.0.0.1, mais rien de mieux au regard de mon souci- oui je comprends qu’en bypassant la résolution du nom ça aille plus vite :grinning:

Bonsoir aux moderateurs, y’a pas un petit coup de pouce pour moi sur la question ? je suis toujours bloqué… merci

Voici le mien :

$dolibarr_main_url_root='https://[IP_SYNO]:[PORT]';
$dolibarr_main_document_root='/volume1/web/dolibarr_test/htdocs';
$dolibarr_main_url_root_alt='/custom';
$dolibarr_main_document_root_alt='/volume1/web/dolibarr_test/htdocs/custom';
$dolibarr_main_data_root='/volume1/web/dolibarr_test/documents';
$dolibarr_main_db_host='localhost';
$dolibarr_main_db_port='3307';
$dolibarr_main_db_name='test_doli';
$dolibarr_main_db_prefix='dbt_';
$dolibarr_main_db_user='****';
$dolibarr_main_db_pass='crypted:**********';
$dolibarr_main_db_type='mysqli';
$dolibarr_main_db_character_set='utf8';
$dolibarr_main_db_collation='utf8_unicode_ci';
// Authentication settings
$dolibarr_main_authentication='dolibarr';

//$dolibarr_main_demo='autologin,autopass';
// Security settings
$dolibarr_main_prod='1';
$dolibarr_main_force_https='1';
$dolibarr_main_restrict_os_commands='mysqldump, mysql, pg_dump, pgrestore';
$dolibarr_nocsrfcheck='0';
$dolibarr_main_instance_unique_id='*************';
$dolibarr_mailing_limit_sendbyweb='0';
$dolibarr_mailing_limit_sendbycli='0';

J’ai le port 3307 pour ma part