Installation Dolibarr 10.0.6-0.4 Problème de connection MYSQL

Bonjour à tous.

Ayant passé 2 jours a essayer d’upgrader Dolibarr 10.0.3 en 10.0.6 sur une CentOS7,
j’ai installé un nouveau serveur, et directement Dolibarr 10.0.6 en RPM.
Installation impeccable. Je me connecte à la page web d’initialisation du logiciel, renseigne le nom de la base, nom et mot de passe de l’utilisateur de la base, et tapes un mot de passe pour l’utilisateur root de mysql.
==> Access denied for user ‹ root ›@‹ localhost › (using password: NO)

Je me dit que le mot de passe de root n’est pas positionné, je lance mysql_secure_installation, qui me permet de définir ce mot de passe.
Je teste avec mysql -P 3306 -u root -p, entre le mot de passe défini précédemment, et arrive sans problèmes dans mysql.

Je relance donc la page web de configuration, re-saisi les paramètres, en veillant bien de mettre le mot de passe défini précédemment de l’utilisateur root
==> Access denied for user ‹ root ›@‹ localhost › (using password: NO)

Comment puis me connecter à Mysql avec Dolibarr ???

Merci d’avance pour votre aide.

Bonjour,

De mémoire, la connexion à sql a changé depuis les appli en php.
Si tu as phpmyadmin (ou un autre) est-ce que tu as le même problème?

Au cas ou, un pense bête que je garde sous le coude ( c’est l’age… :joy: )
Vu qu’il me semble que CentOS est passé sur mariadb (comme Debian - je monte que ça…)

Configuration de l’accès à mysql dans mariadb pour le html :

[email protected]:/etc/apache2/conf-available# mysql -u root -p

Enter password:

Welcome to the MariaDB monitor. Commands end with ; or \g.

Your MariaDB connection id is 38

Server version: 10.3.18-MariaDB-0+deb10u1 Debian 10

Copyright © 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type ‹ help; › or ‹ \h › for help. Type ‹ \c › to clear the current input statement.

MariaDB [(none)]> USE mysql;

Reading table information for completion of table and column names

You can turn off this feature to get a quicker startup with -A

Database changed

MariaDB [mysql]> SELECT plugin FROM user WHERE user=‹ root ›;

±------------+

| plugin |

±------------+

| unix_socket |

±------------+

1 row in set (0.000 sec)

MariaDB [mysql]> UPDATE user SET plugin=’’ WHERE User=‹ root ›;

Query OK, 1 row affected (0.003 sec)

Rows matched: 1 Changed: 1 Warnings: 0

MariaDB [mysql]> FLUSH PRIVILEGES;

Query OK, 0 rows affected (0.001 sec)

MariaDB [mysql]> EXIT;

Bye

Bonjour d.laroche.

Merci pour ta réactivité.

  1. j’ai volontairement installé Mysql et non Mariadb pour des problèmes de mise a jour de Dolibarr par RPM. En effet, sur les versions précédentes j’étais en mariadb, et la mise à jour de Dolibarr par YUM n’était pas possible car il trouvait des problèmes de dépendences avec Mysql-server. le contournement consistait à installer avec rpm et non yum, mais du coup la base YUM n’était plus d’équerre.

  2. La connexion avec phpmyadmin fonctionne parfaitement.

Bon ! j’ai passé 2 jours, mais ça a l’air OK maintenant. Plusieurs remarques :

  1. il ne suffit pas de désinstaller le rpm avec yum, il faut également supprimer le répertoire /var/lib/dolibarr.
  2. Lors de la première connexion après install, le logiciel demande le nom de la base, l’utilisateur admin ainsi que le mot de passe de l’utilisateur root de mysql. Ne pas saisir de mot de passe pour ROOT !!! a chaque fois que je l’ai fait, cela n’a pas marché, même en l’ayant modifié plusieurs fois manuellement avec l’outil mysql.
  3. lorsque vous revenez en arrière pour resaisir les infos sur la base de données, les champs que vous avez renseignés ne sont pas conservés, et sont remplacés par les valeurs par défaut.
  4. Quand enfin on réussi à passer le cap des infos mysql, on tombe sur une erreur sur la ligne
    GRANT ALL PRIVILEGES ON nom_de_la_base.* TO ‹ administrateur_de_la_base ›@‹ localhost › IDENTIFIED BY ‹ ***** ›
    Il faut alors entrer dans mysql en ligne de commande, et rentrer la ligne suivante :
    GRANT ALL PRIVILEGES ON nom_de_la_base.* TO ‹ administrateur_de_la_base ›@‹ localhost ›;
    en remplaçant nom_de_la_base par le nom que vous avez assigné à votre base de donnée, et administrateur_de_la_base par ce que vous avez saisi dans le champ adéquat lors de la première connexion.
    ATTENTION : l’editeur utilisé pour saisir ce texte remplace les simples quotes par des caractères « supérieur » et « inférieur »; C’est bien des simples quotes qu’il faut utiliser.
  5. plusieurs messages d’erreurs sur des duplicates, cliquez sur continuer pour finir l’installation.

Point positif : Une fois la 10.0.6 installée et opérationnelle, le passage à la 11.0.0 se fait comme une fleur avec yum update.

Vivement la prise en charge de MariaDB dans les upgrade de dolibarr par yum.

Merci à ceux qui se sont penchés sur mon problème.