Génération code-barres

Bonjour,

Mon module code-barres semble être bien configuré mais, lors de la génération sur les fiches produits l’image du code-barre ne s’affiche pas.
Avez-vous déjà rencontré ce problème ?

Pièces jointes :

Configuration_des_codes-barres_-_2018-08-31_11.06.42.png
bjr
Ds config du module code barres avez vous activé le tcpdf barcode ?

Oui la configuration est identique à la votre.

¨Pouvez vous mettre une image sur un produit ? >>fichier joint
S afiche t elle sur la fiche ?

php curl est activé ?

oui j’ai la possibilité de mettre une photo. Je ne sais pas pour le PHP CURL.

Outils admin>>infos php

cURL support…

Oui la fonction est activée.

Pièces jointes :

Je crois que j ai compris votre pb :cheer:
vous avez definis un masque personnalisé isbn ( alors que ca ressemble pas a de l isbn :whistle: )

Enlevez votre masque et mettez un type "standart "

Un type standard ? J’ai suivi les instructions sur l’aide pour le gestionnaire de code-barres produit.
J’ai tenté avec : {0000000000000} mais, toujours pareil !

desactiver votre masque
et juste au dessus ds autre options choisissez un type de code barres pour vos produits…

Mon masque est désactivé, je choisi dans autres options ISBN par défaut pour les produits (comment va-t-il générer un code sans avoir de base ?).
L’image n’apparaît toujours pas et il n’y a pas de code généré !

le moteur tcpdf embarque contient les codes de bases :wink:

Verifiez par mondolli/htdocs/install que

PHP prend en charge les fonctions graphiques GD.

Oui le fonction graphique GD de PHP est bien prise en charge.

Désolé mais la je vois pas :pinch:

Pour infos quelle version de dolli ? Quel version de php ?
Avez vous essayé de desactiver le module code barres ?

Version Dolibarr : 8.0.0
Version PHP : 5.6.36

Les codes suivants ne fonctionnent pas :
- EAN13
- EAN8
- ISBN
- UPC

bonjour
avez vous resolu votre probleme
merci

Je me répond a moi même quand j enlever la creation automatique de code barre ça marche bien,

Bonjour,

Le problème est résolu. Après avoir configuré et redémarrer Doli cela fonctionne.

Merci.