En finir avec Jalon/Milestone - Action commune ?

Bonjour à tous,

Je lis le forum depuis longtemps mais c’est mon premier post.

Dolibarr est en production depuis presque un an; dès le départ j’ai fait l’acquisition du module Jalon car c’est important pour moi de pouvoir regrouper et/ou cacher les descriptions dans les devis/factures.

Rapidement je me suis aperçu que le module avait des bugs reproductibles, j’en ai fait part au Dolistore et aux responsables du modules par mail et téléphone mais malgré mon attente de 9 mois pas d’accouchement de code :wink:

La situation s’empire maintenant puisque je suis « scotché » en 3.6.2 (a cause des bugs* et de l’incompatibilité de ce maudit Jalon).

Je lance donc un appel a l’aide pour qui voudrai bien s’occuper sérieusement et définitivement de la correction de ce module.

Je suis prêt a participer économiquement a cette correction si le cout et le délai sont raisonnables.

Bien entendu je ne suis pas fermé a une collecte commune, car j’imagine que je ne doit pas être le seul « planté » ou déçu.

Bien à vous,

Christophe.

www.dolibarr.fr/forum/t/jalon-milestone-bug-sur-le-calcul-du-total/20471/1

www.dolibarr.fr/forum/t/resolu-modules-milestone/20504/1

www.dolibarr.fr/forum/t/milestone-et-saut-de-page/18274/7

bonjour,
alors oui j’avoue que le dev a trainé mais la vie est parfois ainsi ! :wink:
je suis en train de faire une refonte du module…
tu as quelle version du module ?

Ah ? votre sujet risque de soulever les foules… puis peut etre la censure???
une réponse que j’avais eue sur un module incomplet, mais c’est normal un module incomplet.

2/ 6 mois plus tard ces fonctions n’ont toujours pas été développé. C’est notre droit, une seule demande en ce sens,d’autre projets au planning. Encore une fois si c’est gratuit c’est à discrétion du développeur. Nous n’avons par ailleurs reçu que peu de retours sur le sujet preuve que le module doit généralement répondre au besoin,

Bonjour,

@Regis : Jalon est en 1.0.6.2 avec un core/lib/pdf.lib fournit par Philippe en Janvier.
Le core est en 3.6.2

@HubZ : Vous avez aussi des problèmes avec Jalon ?
Les problèmes de planning je peut tout à fait les comprendre car beaucoup de dev autour de Dolibarr semblent être en freelance, ils sont donc probablement « au four et au moulin », et doivent forcement partager leur temps entre l’altruisme et le commerce.
La ou je vous rejoint c’est qu’effectivement quand un développeur fait le choix de passer du code au modèle payant le développeur ne devrait pas être surpris du clientélisme, voir de l’impatience des acheteurs (dans mon cas je pense que 9 mois d’attente on ne peut pas parler d’impatience ;).

Bonjour,

Bon, a priori personne de motivé pour une action commune.

Si j’avais su que ce module payant m’handicaperait autant dans mon quotidien et mes montées de version !

Y a t il qqn ou une entreprise sérieuse et disponible pour m’aider de manière plus privée ?

Je suis en 3.8… et je ne compte plus les modules que j’ai dû abandonner voir désinstaller parce qu’il n’était plus maintenu même depuis la 3.7 j’aimerais en faire la liste mais elle est trop longue…
J’ai soulevé le problème du maintien des modules à jour avec les version stable de Dolibarr mais personne n’était de mon avis c’est-à-dire imposer que le module soit versé dans le coeur de Dolibarr s’il n’est plus maintenu depuis plus de deux version stable.

  1. régis vous a répondu il y a 1 semaine ici pour dire qu’il faisait une refonte du module.
  2. une petite recherche dans les forums vous permettrait de trouver des solutions alternatives (voire gratuites) à ce module
  3. en tant que développeur de module, je ne peux être d’accord avec Hubz (dont je serais curieux de voir la longue liste…)
    La majorité de nos clients sont en 3.5 et nos modules aussi ! Je commence juste à les tester en 3.6. Après, on en revient toujours à la notion de « version stable »…

Voika je me doutais bien que j’avais encore soulever les foules et me mettre des gens a dos avec ce sujet alors excusez moi de l’avoir évoqué.
Dommage qu’il n’y ait pas un travail commun entre les utilisateurs et les développeurs pour profiter d’un logiciel stable à jour et avec des fonctionnalités modernes. (Que ce soit les modules ou les nouvelles fonctionnalités des.6 .7 et.8…)
Si tout le monde était en 3.5 ou trois. 6 alors quel serait l’intérêt de faire des version supérieures?

quel intérêt de changer de version tous les 6 mois ? et pour qui ?

1 J'aime

Euh… Les startup ?

montrer que dolibarr est un projet actif, cela s’appel aussi courir dans le mur car à chaque version on ne voit rien qui change…

on peut très bien avoir un projet actif, qui sort des nouvelles versions (moins souvent) mais sans oser prétendre qu’elles sont stables

Bonjour Altatof, merci de vous joindre a la conversation, j’ai eu peur que ce sujet n’intéresse que Hubz et moi.

Je trouve cette proposition de Hubz de reverser en core ce qui n’est plus maintenu depuis trop longtemps plutôt intéressante.

Effectivement Régis a répondu mais je me permet de rappeler que j’ai été vraiment patient (1 an !) , ouvert au dialogue/test (notamment dans mes échanges auprès de Philippe) et même prêt a financer en collectif en perso pour que les bugs soient corrigés…

Je sais aussi que ce n’est pas la première fois que cette promesse de refonte/correction est dite et/ou écrite, permettez moi donc d’en douter !

Sans vouloir changer tous les 6 mois (je suis tjs en 3.6.2) je constate quand même que la situation s’aggrave car :

  1. Les bugs ne sont pas corrigés
  2. Si je passe en 3.8 je regresse en fonctionnalités, cf : www.dolibarr.fr/forum/t/jalon-milestone-suite-maj-3-8-0/21520/1 :unhappy:

Quand aux solutions alternatives j’ai testé le module « sous total » mais il ne couvre pas l’intégralité des fonctions.
En gratuit vous pensez a quoi ? Avez vous svp un mot clef ou une URL que je puisse rechercher et tester a nouveau ?

Au passage il me faut aussi trouver un moyen de sortir mes données de ce foutu module car si je le quitte il me semble que mes datas sont dans une table non standard…

Bien à vous,

Christophe

@ChrisG: oui je pensais à sous-total; sans vouloir faire de la pub à ATM et de la contre-pub pour Régis; c’est une alternative parfois intéressante.

@ChrisG je me joins à votre réflexion, et je suis désolé d’avoir éveillé du troll dans ce post avec le reversement dans le core de ce qui est trop poussiéreux et jamais dépoussiéré, et surtout, bloquant, comme pour vous.

Je ne possède pas le module, mais étant féru de nouvelles fonctionnalités et testant tout « avant que ça bêta », je m’inquiète des choses qui fonctionnaient et étaient utiles (pour moi c’était ReStock, Defrance m’a filé un patch, mais ça bricole toujours sous le capot).

Et je me dis que c’est dommage : sans MàJ des modules et suivi des versions, mauvaise pub pour le Dolistore, plus d’achats sur Dolistore, pas de $$$ pour les dévs, pas de $$$ pour l’asso, pas de cercle vertueux.

Bref, on va pas se battre pour si peu, j’ai pas besoin du module sous-total mais je peux en financer la moitié avec vous (oh punaise je vais être banni) !

Tiens en parlant de ca, j’attend toujours ton retour pour savoir si le problème était réglé et que je puisse officiellement diffuser le patch… moi qui pensait que c’était le truc qui t’empêchait limite d’avoir une vie sociale…

Moi ce que je trouve dommage c’est que l’on fasse des discussions de comptoir mais que pour faire avancer les choses il n’y a personne.
qui s’inscrit à l’association et s’implique pour faire évoluer les choses si possible dans le bons sens?
comme le chantait IAM; tous les burnes et rien dans les urnes…

Ensuite je le répète, un module à l’abandon, cela se reprend, j’ai personnellement fait évolué et corrigé un module qui n’était plus à jour à la demande d’un de mes clients. j’aurai pu le remettre en vente mais j’ai préféré l’envoyé corrigé à son développeur initiale

Bref, ce que fait régis ne vous convient pas, trouver un développeur et faite-lui corriger le soucis

Bonjour
Le module étant en licence GPL, peut-on demander à publier une portion de code sur le forum pour essayer de voir ce qui cloche et faire avancer? Par exemple la fonction printobjectline de la classe ActionsMilestone
Sans publier l’intégralité, bien sur…
Puisque dans la 3.8 les hook ont été modifié, il doit pas y avoir grand chose à changer
Method must not return a string but an int (0=OK, 1=Replace, -1=KO) and set string into ->resprints

Fred

d’ailleurs c’est vachement pratique les hooks qui changent de comportement à chaque version majeure (pourquoi d’ailleurs ?). Parce que les hooks, c’est quand même fait pour les modules externes… alors pourquoi mettre des bâtons dans les roues des développeurs de modules ?

Bonjour à tous,

Je viens d’apprendre (Merci Mr Grand) que le module est en 2.0.0…j’ai creusé le changelog et a priori il a été refait, corrigé et est compatible avec Dolibarr 3.8 !

Avant de me précipiter vers une mise à jour de ma 3.6.8 en 3.8 (j’attends depuis longtemps certaines améliorations dispo en 3.8, en particulier la gestion des SN en natif) je souhaiterai avoir vos retours d’expériences sur la maj (avant ou après la maj Dolibarr d’ailleurs) vers cette version du module Jalon ?

Autres question a la communauté d’utilisateurs de ce module (ou aux développeurs) :

  1. est ce que cette maj corrige le bug que j’avais signalé l’année dernière ( a la génération du PDF lorsqu’on demande a masquer le prix des lignes incluses dans le Jalon le prix des lignes pourtant exclues de ce Jalon se trouvent eux aussi masqués + problème a la transformation en facture d’anciens devis) ?
    Pour info ce bug est présent sur ma version actuelle : 1.0.6.2 , peut etre le « Fix: compatibility with Dolibarr 3.6 » qu’on peut lire dans le changelog de la 1.0.6.3 (version a laquelle je n’ai pas eu accès) a résolu ce problème ?

  2. Quel est l’impact/contenu du « New: complete refactorization » qu’on peut lire dans le changelog ?

Merci d’avance pour vos retours,

Bonne soirée,

Chris

Bonsoir à tous,

J’en reviens à la mauvaise expérience que j’ai faite récemment en voulant passer en 3.8.1, perdant plus de fonctionnalités que j’en gagnais, et me heurtant à l’incompatibilité des modules que j’utilisais. Résultat, retour en arrière (3.6.3) et plus touche à Dolibarr.

J’ai pris des infos sur ATM sous-total. Les fonctions ne sont pas compatibles avec mon usage.

Pour moi, malheureusement, Dolibarr est un outils fait par des développeurs, pour des développeurs… Il est beaucoup trop compliqué, voir impossible pour un non initié, de pouvoir entretenir, vérifier, modifier, remonter les bugs, tester… et continuer à produire. C’était la raison de mon poste " Retour d’expérience d’un petit entrepreneur".

Il est même frustrant ce Dolibarr. Et oui, on vous met sous le nez une nouvelle version avec les fonctionnalités que vous attendez depuis longtemps, pour au final vous conseiller de ne pas l’installer…

Bref, assez déçu, malgré les très bons conseils et supports qu’ont pu m’apporter généreusement Grandoc et DeFrance.

A bientôt.

1 J'aime