Création sous menu ne fonctionne pas

Bonjour !

J’ai créé pour ma boite un module accompagné d’une page permettant de sélectionner des options pour le module en question.

$this->menu[$r]=array(	'fk_menu'=>'fk_mainmenu=of',			
		'type'=>'left',			// This is a Top menu entry
		'titre'=>'Scan postes OF',
		'mainmenu'=>'of',
		'leftmenu'=>'barcodescanner',
		'url'=>'/cliacropose/barcodetimemanagerindex.php',
		'langs'=>'[email protected]',	      
		'position'=>320+$r,
		'enabled'=>'',	
		'perms'=>'$user->rights->cliacropose->cliacropose->read',	
		'target'=>'',
		'user'=>2);
		$r++;

$this->menu[$r]=array(	'fk_menu'=>'fk_mainmenu=of,fk_leftmenu=barcodescanner',			// Put 0 if this is a top menu
		'type'=>'left',			// This is a Top menu entry
		'titre'=>'Postes déclaratifs',
		'mainmenu'=>'of',
		'leftmenu'=>'barcodescanner',
		'url'=>'/cliacropose/barcodescanner_settings.php',
		'langs'=>'[email protected]',	     
		'position'=>320+$r,
		'enabled'=>'',			
		'perms'=>'$user->rights->cliacropose->cliacropose->read',			
		'target'=>'',
		'user'=>2);				
		$r++;

Dans le descripteur du module, j’ai indiqué comme vous pouvez le voir que les entrées menu de mon module apparaîtront dans le module OF. L’entrée Scan postes OF apparaît bien, en revanche le sous-menu Postes déclaratifs n’apparait pas. Je ne vois absolument pas ce que j’ai pu mal faire pour que ça n’apparaisse pas. J’ai bien désactivé/réactivé mon module mais rien n’y fait.

Merci d’avance pour vos réponses.

Corentin

Bon, j’ai au final utilisé les paramètres de création de menus, et je me suis pas compliqué la vie