Création d'un plan comptable base 6 chiffres

Bonjour,

Je cherche à créer directement dans le module Comptabilité- Configuration - Modèle de plan de compte un PCMN belge décimalisé sur 6 chiffres. (1 10 100 100000) en n’autorisant la saisie d’écritures que sur les comptes à 6 chiffres. Dès l’introduction du deuxième compte titre je me suis retrouvé face à l’erreur suivante :
« Error Duplicate entry ‹ 1-1-PCG99-BASE › for key ‹ uk_accounting_account › »

En cherchant dans les tables de la base de données je constate plusieurs choses : (les initiales de ma DB sont arp_)
la table arp_accounting_system a dans le champ « active » 0 a toutes les lignes sauf à la ligne du plan comptable que je viens de créer qui est positionné à 1 (correct donc)
la table arp_accounting_account a par contre conservé l’ancien plan comptable dans son champ fk_pcg_version à savoir PCG99_ABREGE
et dans cette même table je constate que le champ account_number est en varchar avec une clef unique sur deux champs un varchar et un numérique (ce qui je crois pourrait être la source de mon message d’erreur) et l’impossibilité de créer un compte 10 après avoir créé le compte 1

Je suis loin d’être un spécialiste mais si un pro pouvait venir à mon secours je lui en serais très reconnaissant ^^

PS : j’ai posté par erreur ce topic sur le forum dolibarr.org j’en fait donc copie ici.
Merci

Pourquoi chercher compliqué quant la réponse est simple, encore faut-il la connaitre :slight_smile:

Merci à Eldy pour ce lien :…/ htdocs/accountancy/admin/index.php?mainmenu=accountancy&leftmenu=accountancy_admin

Très utile pour tous les Belges et tous les Suisses

Bonjour,
pourriez vous donner plus de détails à propos de la manip à faire pour pouvoir créer et utiliser les comptes comptables à 6 chiffres, svp?
J’utilise la dernière version stable de Dolibarr.
Merci d’avance

Salut SPH,

avec le module compta avancée activé (Accueil > configuration > modules > compta (avancée)

Ces options sont disponibles dans Comptabilité > configuration > générale

1 J'aime

Merci bcp!!! j’avais pas mal personnalisé mais j’avais passé à côté de ce détail :wink: