Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Problème API

Problème API il y a 1 mois 18 heures #115473

  • toolinnn
  • Portrait de toolinnn
  • Hors ligne
  • Fresh Boarder
  • Messages : 15
  • Karma: 0
Bonjour à tous,

Je rencontre le même problème sur une update de dolibarr 10.0.1

J'ai bien généré un clé api pour le super utilisateur, et que je la saisisse dans l’explorer ou non, j'ai ça :

{"messages":["attribute paths is not of type `object`"],"schemaValidationMessages":[{"level":"error","domain":"validation","keyword":"type","message":"instance type (array) does not match any allowed primitive type (allowed: [\"object\"])","schema":{"loadingURI":"swagger.io/v2/schema.json#","pointer":"/...":{"pointer":"/paths"}}]}

auriez vous une solution ?
L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 1 mois 11 heures #115494

  • ksar
  • Portrait de ksar
  • Hors ligne
  • Admin
  • Bijour!
  • Messages : 1017
  • Remerciements reçus 280
  • Karma: 14
Bonjour,

Vous essayez d'acceder à quelle adresse ?
L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 1 mois 20 minutes #115504

  • toolinnn
  • Portrait de toolinnn
  • Hors ligne
  • Fresh Boarder
  • Messages : 15
  • Karma: 0
Bonjour,

Quand j'accède à l'URL : https://domaine/htdocs/api/index.php/explorer

quand j'entre dolikey est appui sur explorer rien s'affiche

Sanstitre.png



Cordialement
Dernière édition: il y a 1 mois 20 minutes par toolinnn.
L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 3 semaines 4 jours #115675

  • toolinnn
  • Portrait de toolinnn
  • Hors ligne
  • Fresh Boarder
  • Messages : 15
  • Karma: 0
Bonjour,

auriez vous une solution ?
L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 3 semaines 4 jours #115676

  • jtraulle
  • Portrait de jtraulle
  • Hors ligne
  • Admin
  • Messages : 261
  • Remerciements reçus 98
  • Karma: 17
Bonjour,

Quel est le serveur Web utilisé ? Apache2 ou nginx ?
Vérifier aussi les logs serveurs (PHP).
L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 3 semaines 4 jours #115689

  • toolinnn
  • Portrait de toolinnn
  • Hors ligne
  • Fresh Boarder
  • Messages : 15
  • Karma: 0
Bonjour,

Le serveur utiliser est nginx :
        location / {
                index index.php index.html index.htm;
                try_files $uri $uri/ /index.php?q=$request_uri;
        }

        # REST API support
        location /htdocs/api {
            if ( !-e $request_filename) {
                rewrite ^.* /htdocs/api/index.php last;
            }
        }

        location ~ \.php$ {
            fastcgi_pass   xxxxxxxxx-sock;
            fastcgi_index  index.php;
            fastcgi_read_timeout 180;
            fastcgi_split_path_info ^(.+\.php)(/.*)$;
            fastcgi_param PHP_VALUE open_basedir="/home/xxxxxxx/www:/tmp";
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
             # Dolibarr Rest API path support
            fastcgi_param  PATH_INFO       $fastcgi_path_info;
            fastcgi_param  PATH_TRANSLATED $document_root$fastcgi_script_name;
            include fastcgi_params;
        }

L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 3 semaines 4 jours #115701

  • jtraulle
  • Portrait de jtraulle
  • Hors ligne
  • Admin
  • Messages : 261
  • Remerciements reçus 98
  • Karma: 17
C'est sûr qu'il y a un truc pas clair avec l'API REST quand le serveur Web utilisé est nginx (j'en ai fait les frais également).
Je pense qu'il faudrait voir au niveau du code pour faire définitivement un FIX sous forme d'une PR GitHub car les différentes bidouilles pour définir le PATH / PATH_INFO / PATH_TRANSLATED ne sont pas hyper perennes.

Voici la config que j'ai pour un nginx 1.16.1 sous Debian Buster :
location ~ [^/]\.php(/|$) {
        fastcgi_read_timeout 180;
        fastcgi_split_path_info ^(.+\.php)(/.*)$;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $fastcgi_script_name;
        fastcgi_param  PATH_TRANSLATED    $document_root$fastcgi_path_info;
        fastcgi_index index.php;
        include fcgi.conf;
        fastcgi_pass xxxxxxxxxxxx.sock;
}

Avec cette config, chez moi pas de soucis (mais peut-être que ça ne fonctionnera pas chez vous ;))

Quelle est la distrib et comment nginx a t'il été installé (dépôts de la distrib ou dépôts officiels de nginx) ?
L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 3 semaines 4 jours #115705

  • toolinnn
  • Portrait de toolinnn
  • Hors ligne
  • Fresh Boarder
  • Messages : 15
  • Karma: 0
bonjour,

quand j'utilise votre configuration j'ai le message : API not found (failed to include API file)


nginx version: nginx/1.17.3
cat /etc/yum.repos.d/nginx.repo
#--------------- On CentOS 7 ---------------
[nginx]
name=nginx stable repo
baseurl=http://nginx.org/packages/centos/$releasever/$basearch/
gpgcheck=1
enabled=1
gpgkey=https://nginx.org/keys/nginx_signing.key

[nginx-mainline]
name=nginx mainline repo
baseurl=http://nginx.org/packages/mainline/centos/$releasever/$basearch/
gpgcheck=1
enabled=1
gpgkey=https://nginx.org/keys/nginx_signing.key

je suis sur centos : CentOS Linux release 7.7.1908 (Core)
L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 3 semaines 4 jours #115706

  • jtraulle
  • Portrait de jtraulle
  • Hors ligne
  • Admin
  • Messages : 261
  • Remerciements reçus 98
  • Karma: 17
Et en laissant include fastcgi_params; au lieu de include fcgi.conf; ?

Quelque part, vu que c'est une CentOS, ça ne m'étonne pas que ça soit différent, par contre, là tout de suite je n'en ai pas sous la main pour tester ;)
L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 1 semaine 16 heures #116391

  • eldy
  • Portrait de eldy
  • Hors ligne
  • Administrateur
  • Messages : 1053
  • Remerciements reçus 50
  • Karma: 107
Pourquoi avoir rajouté ceci ?

# REST API support
location /htdocs/api {
if ( !-e $request_filename) {
rewrite ^.* /htdocs/api/index.php last;
}
}

Normalement on a juste à avoir un un handler sur la racine de dolibarr. Le chemin /api étant une url de dolibarr comme les autres.
L'administrateur a désactivé l'accès en écriture pour le public.

Problème API il y a 1 semaine 11 heures #116415

  • toolinnn
  • Portrait de toolinnn
  • Hors ligne
  • Fresh Boarder
  • Messages : 15
  • Karma: 0
je trouver ca sur internet, en plus ca fonctionnent bien avant que fasse un mise à jour de dolibarr vers 10.0.2
L'administrateur a désactivé l'accès en écriture pour le public.