Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi
  • Page :
  • 1
  • 2

SUJET : Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 2 mois 2 semaines #104722

  • royerjy
  • Portrait de royerjy
  • Hors ligne
  • Junior Boarder
  • Messages : 20
  • Karma: 0
Bonjour,

Je tente de convertir une association à Dolibarr avec un domaine chez Lautre.net.

Tout se passait bien, sauf que la mise à jour vers 8.0.4 à partir de 8.0.3 ne se fait pas. Page blanche à la fin et reproposition de la mise à jour à la connexion suivante.

Les prérequis semblent bons :
Vérification des prérequis:
Ok Version de PHP 5.6.36-0+deb8u1 (Plus d'information)
Ok Ce PHP prend bien en charge les variables POST et GET.
Ok Ce PHP prend en charge les sessions.
Ok Ce PHP prend en charge les fonctions graphiques GD.
Ok PHP supporte l'extension Curl
Ok Ce PHP prend en charge les fonctions UTF8.
Ok Votre mémoire maximum de session PHP est définie à 128M. Ceci devrait être suffisant.
Ok Le fichier de configuration htdocs/conf/conf.php existe.
Ok Le fichier htdocs/conf/conf.php est modifiable.

Version dernière mise à jour: 8.0.3
Version programmes: 8.0.4

Si, à la place d'effectuer la mise à jour, je lance une "Première installation", j'obtiens l'erreur :
"The requested URL /install/step2.php was not found on this server."
Comme le fichier existe, si j'active le lien à nouveau, step2.php s'exécute et fournit l'erreur :
"Parameter action=set not defined"

J'ai tenté de supprimer le .htaccess et de travailler en http et non en https, mais pas de mieux.

Il me semble avoir eu le même comportement, lors d'un premier essai avec une version antérieure de Dolibarr, ce qui m'avait fait renoncer à utiliser Dolibarr pour cette association.

Il semble y avoir peu d'utilisateurs de Dolibarr chez Lautre.net. J'ai sollicité de l'aide mais je crains de ne pas en avoir. Idée sur ce qu'il faudrait faire ? Merci pour l'aide.

Librement.

Jean-Yves ROYER
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 2 mois 2 semaines #104835

  • philazerty
  • Portrait de philazerty
  • En ligne
  • Gold Boarder
  • Intégrateur Mon-Dolibarr.fr Hébergement Infogéré
  • Messages : 5574
  • Remerciements reçus 818
  • Karma: 111
Bonjour
Déjà un PHP 5 ça commence à dater. Avec une version 8 ça devient limite je crois même s'il me semble vque la version 5.7 est supportée. Ceci peut expliquer des erreurs.
Ensuite il y a peut-être des erreurs de droits ou de transfert. Supprimer tout le htdocs sauf le confort et repousser la 804
@+
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 2 mois 2 semaines #104860

  • Arre
  • Portrait de Arre
  • En ligne
  • Modérateur
  • Messages : 1197
  • Remerciements reçus 266
  • Karma: 35
C’est le dossier « conf » pas « confort » ... un correcteur orthographique a du passer par là ;)
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: philazerty

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 2 mois 2 semaines #104913

  • royerjy
  • Portrait de royerjy
  • Hors ligne
  • Junior Boarder
  • Messages : 20
  • Karma: 0
Nouvelle tentative avec le même résultat. Je tente d'obtenir du PHP7 chez Lautre.net avant de tester à nouveau.
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 2 mois 21 heures #105639

  • royerjy
  • Portrait de royerjy
  • Hors ligne
  • Junior Boarder
  • Messages : 20
  • Karma: 0
Bonjour,

Lautre.net vient de mettre à jour en PHP 7.

Apparemment, il manque des options dans le PHP car j'obtiens les alertes suivantes :

Version de PHP 7.3.0-2 (Plus d'information)
Ok Ce PHP prend bien en charge les variables POST et GET.
Ok Ce PHP prend en charge les sessions.
Error Ce PHP ne prend pas en charge les fonctions graphiques GD. Aucun graphique ne sera disponible.
Error Votre version de PHP ne supporte pas l'extension Curl
Ok Ce PHP prend en charge les fonctions UTF8.
Ok Votre mémoire maximum de session PHP est définie à 128M. Ceci devrait être suffisant.
Ok Le fichier de configuration htdocs/conf/conf.php existe.
Ok Le fichier htdocs/conf/conf.php est modifiable.

J'ai néanmoins tenté l'installation, mais j'obtiens rigoureusement les mêmes résultats qu'en PHP 5.6. Les erreurs sont-elles rédhibitoires ? Si oui, que faut-il demander à Lautre.net dont les administrateurs ne doivent pas être des spécialistes de Dolibarr. Pour le moment, je suis toujours planté...

Merci. Librement.

JYR
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 2 mois 1 heure #105674

  • cdninformatique
  • Portrait de cdninformatique
  • Hors ligne
  • Senior Boarder
  • Messages : 73
  • Remerciements reçus 5
  • Karma: 0
Bonsoir,

Savez-vous indiquer quel système d'exploitation serveur ?
Il doit manquer des extensions telles que "php-gd", etc...
Donnez-nous les infos avant de tenter peut-être ?

@bientôt
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 1 mois 3 semaines #105738

  • cdninformatique
  • Portrait de cdninformatique
  • Hors ligne
  • Senior Boarder
  • Messages : 73
  • Remerciements reçus 5
  • Karma: 0
philazerty écrit:
Bonjour
Déjà un PHP 5 ça commence à dater. Avec une version 8 ça devient limite je crois même s'il me semble vque la version 5.7 est supportée. Ceci peut expliquer des erreurs.
Sur mon serveur (SME 9.2, base Centos 6), j'ai installé une contrib qui permet d'être en version 5.6 de php.
J'utilise Dolibarr 8.0.4 et ça fonctionne bien.
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 1 mois 3 semaines #105739

  • cdninformatique
  • Portrait de cdninformatique
  • Hors ligne
  • Senior Boarder
  • Messages : 73
  • Remerciements reçus 5
  • Karma: 0
royerjy écrit:
S'il manquait des modules, ils ne seraient probablement pas la cause du plantage à la mise à jour, qui n'a pas changé entre les deux versions de PHP.
C'est pourtant ce que signale le message d'erreur (à quoi serviraient-ils sinon :) )
Il y a deux soucis : php-gd ne doit pas être installé et curl pareil)
Le serveur Debian est en 9.1 donc pas à jour
[email protected]:~$ cat /etc/debian_version 
9.6
Dernière édition: il y a 1 mois 3 semaines par cdninformatique. Raison: oubli debian version
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 1 mois 3 semaines #105872

  • royerjy
  • Portrait de royerjy
  • Hors ligne
  • Junior Boarder
  • Messages : 20
  • Karma: 0
Bonjour,

Un administrateur de Lautre.net a ajouté les modules de PHP qui manquaient.

Le nouveau contexte d'installation :

Vérification des prérequis:
Ok Version de PHP 7.2.14-1+0~20190113100742 (Plus d'information)
Ok Ce PHP prend bien en charge les variables POST et GET.
Ok Ce PHP prend en charge les sessions.
Ok Ce PHP prend en charge les fonctions graphiques GD.
Ok PHP supporte l'extension Curl
Ok Ce PHP prend en charge les fonctions UTF8.
Ok Votre mémoire maximum de session PHP est définie à 128M. Ceci devrait être suffisant.
Ok Le fichier de configuration htdocs/conf/conf.php existe.
Ok Le fichier htdocs/conf/conf.php est modifiable.

Version dernière mise à jour: 8.0.4
Version programmes: 8.0.4

Malheureusement, j'ai toujours le même problème de terminaison sur une page blanche par :
"Mise à jour
7.0.* ou 8.0.0 -> 8.0.*"

et le manque d'un fichier par
"Première installation"

pourtant tout semble OK :
"Enregistrement du fichier de configuration ../conf/conf.php Ok
Rechargement des informations depuis le fichier de configuration. Ok
Connexion au serveur (Utilisateur rerschablais_erp) : sql.lautre.net Ok
Connexion à la base (Utilisateur rerschablais_erp) : rerschablais_erp Ok"

Not Found

The requested URL /install/step2.php was not found on this server.

Pourtant le fichier existe au bon endroit et peut se lancer. Un détail de configuration quelque part ?


j'obtiens :

"Installation ou mise à jour de Dolibarr - Création des objets de la base
Parameter action=set not defined"


Merci de votre aide.

Librement.

JYR
Dernière édition: il y a 1 mois 3 semaines par royerjy. Raison: Suppression adresse
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 1 mois 3 semaines #105874

  • pm17
  • Portrait de pm17
  • En ligne
  • Modérateur
  • Linux/Mac/Windows Un petit merci sur mon profil
  • Messages : 918
  • Remerciements reçus 121
  • Karma: 11
Bjr

Deja le truc qui est bizarre
Version dernière mise à jour: 8.0.4
Version programmes: 8.0.4


Le php Version de PHP 7.2
je sais pas si dolli l apprecie tres bien pour le coup


Bref
Avez vous des donnes a recup ?
pouvez vous acceder a phpmyadmin ?
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 1 mois 3 semaines #105876

  • royerjy
  • Portrait de royerjy
  • Hors ligne
  • Junior Boarder
  • Messages : 20
  • Karma: 0
Je vais refaire une installation complète en 8.0.4.

Pour le moment, j'ai une copie sur ma machine qui fonctionne. Donc rien à sauvegarder sur le serveur. J'ai accès à PHPMyAdmin qui permet de gérer les bases MySQL.

Merci pour la réponse rapide. A+. JYR
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 1 mois 3 semaines #105877

  • pm17
  • Portrait de pm17
  • En ligne
  • Modérateur
  • Linux/Mac/Windows Un petit merci sur mon profil
  • Messages : 918
  • Remerciements reçus 121
  • Karma: 11
Si vs avez rien a sauvegarder
perso je vs conseillerais de repartir de zero
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 1 mois 3 semaines #105878

  • gmilad
  • Portrait de gmilad
  • Hors ligne
  • Gold Boarder
  • Dolibarr sur Ovh mutualisé
  • Messages : 162
  • Remerciements reçus 33
  • Karma: 1
Bonsoir,
pm17 écrit:
Le php Version de PHP 7.2
je sais pas si dolli l apprecie tres bien pour le coup

Si si depuis la version 7.00 voir le Changelog
pm17 écrit:
Si vs avez rien a sauvegarder
perso je vs conseillerais de repartir de zero

Idem.

Mais surtout il faut impérativement supprimer les adresses présentes dans votre message.

Amicalement,
Gaëtan.
Dernière édition: il y a 1 mois 3 semaines par gmilad. Raison: Rajout pour la version PHP 7.2
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 1 mois 3 semaines #105880

  • royerjy
  • Portrait de royerjy
  • Hors ligne
  • Junior Boarder
  • Messages : 20
  • Karma: 0
Je viens de tout refaire à partir d'une base vide et d'un dossier vide sur le serveur et je tombe sur la même erreur à l'installation primitive :
Not Found

The requested URL /install/step2.php was not found on this server.
Apache/2.4.25 (Debian) Server at sorry Port 80"

Dans les mêmes conditions en PHP 5.6, je n'avais pas eu de difficulté avec la 8.0.3.

Le fichier step2.php existe bien puisque je peux le lancer en réactivant le chargement, mais il semble manquer au moins un paramètre :
"Dolibarr logo
8.0.4

Installation ou mise à jour de Dolibarr - Création des objets de la base
Parameter action=set not defined"

La base de données est remplie avec 250 tables bien recréées.

Toujours bloqué...

A la prochaine... Merci.
Dernière édition: il y a 1 mois 3 semaines par royerjy. Raison: Suppression adresse
L'administrateur a désactivé l'accès en écriture pour le public.

Plantage mise à jour 8.0.3 vers 8.0.4 chez Lautre il y a 1 mois 3 semaines #105881

  • gmilad
  • Portrait de gmilad
  • Hors ligne
  • Gold Boarder
  • Dolibarr sur Ovh mutualisé
  • Messages : 162
  • Remerciements reçus 33
  • Karma: 1
Bonsoir,

Apparemment ça fonctionne car j'arrive maintenant sur l'écran de connexion.

Pouvez-vous confirmer ?

Sinon je pense à un problème de time-out soit sur le PHP soit sur le sql.

Mais surtout il faut impérativement supprimer les adresses présentes dans vos messages.

Amicalement,
Gaëtan.
Dernière édition: il y a 1 mois 3 semaines par gmilad.
L'administrateur a désactivé l'accès en écriture pour le public.
  • Page :
  • 1
  • 2