Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : logo société disparu après mise à jour

logo société disparu après mise à jour il y a 3 ans 3 mois #68659

  • Arre
  • Portrait de Arre
  • Hors ligne
  • Modérateur
  • Envie de participer ? wiki -> adhérer à l'asso :)
  • Messages : 1454
  • Remerciements reçus 337
  • Karma: 42
Intéressant cette histoire de corruption :)

Peux tu écraser ton logo uploadé via dolibarr, via FTP ?

Si c'est le script d'upload qui le corrompt, l'écraser en FTP devrait "résoudre" le problème.

Et ensuite, s'attaquer à la partie script pour voir d'où ça vient...
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68661

Bonjour Fred
Pas d'erreur affichée après ouverture avec notepad++ et Atom des images.
Les fichiers ne doivent pas être complètement illisibles en tout cas parce que j'arrive à réparer le fichier Word.
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68662

  • frederic34
  • Portrait de frederic34
  • Hors ligne
  • Gold Boarder
  • @NetLogic
  • Messages : 1263
  • Remerciements reçus 338
  • Karma: 60
Bonjour
Est tu sûr d'avoir changé tous les dolibarr-test du fichier conf?

Fred
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68663

Désolé Arre mais c'est un test que j'avais déjà réalisé sur le FTP.
En réalité, le fichier n'est corrompu que lorsque je le télécharge à partir de la GED.
Pour moi le fichier n'est pas corrompu par le script d'upload parce que sinon je ne pourrais pas l'ouvrir même en le téléchargeant via FTP.
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68664

La preuve en image Fred ^^
En pièce-jointe la copie de mon conf.php , j'ai juste remplacé le vrai nom de domaine car je ne veux pas le mentionner ^^
Pièces jointes :
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68665

  • frederic34
  • Portrait de frederic34
  • Hors ligne
  • Gold Boarder
  • @NetLogic
  • Messages : 1263
  • Remerciements reçus 338
  • Karma: 60
Bonjour
Ne serait ce pas plutot:
$dolibarr_main_data_root='/srv/data/web/vhosts/www.tasociete.com/htdocs/dolibarr/htdocs/documents';

Fred
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68666

Non, pour le coup je n'essai pas car les documents se trouvent à la racine de l'instance dans le dossier documents.
Si ce chemin n'était pas correct, je ne pourrais pas télécharger les factures générées au format PDF (qui comportent bien le logo soit dit en passant)

Je pense de plus en plus à une réinstallation qui serait peut être plus simple finalement.
Dernière édition: il y a 3 ans 3 mois par j-francoisbaron.
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68667

  • Sk1z0
  • Portrait de Sk1z0
  • Hors ligne
  • Senior Boarder
  • Messages : 47
  • Remerciements reçus 18
  • Karma: 0
Juste comme ca,

Est ce que php5-gd pourrait etre en cause ?


++
sk1z0
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68668

  • frederic34
  • Portrait de frederic34
  • Hors ligne
  • Gold Boarder
  • @NetLogic
  • Messages : 1263
  • Remerciements reçus 338
  • Karma: 60
Bonjour
Est-ce que:
viewimage.php?cache=1&modulepart=companylogo&file=logo-societe.jpg

renvoie l'image originale et pas le thumbnail
et est ce que tu as le dossier thumbs avec les miniatures?

Fred
Dernière édition: il y a 3 ans 3 mois par frederic34.
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68669

  • philazerty
  • Portrait de philazerty
  • Hors ligne
  • Gold Boarder
  • Intégrateur Mon-Dolibarr.fr Hébergement Infogéré
  • Messages : 5712
  • Remerciements reçus 855
  • Karma: 112
Bonjour
vous dites vos documents sont à la racine ?
Ne devriez vous pas avoir dans ce cas :
$dolibarr_main_data_root='/srv/data/web/vhosts/www.tasociete.com/documents';
Curieuse installation sinon car vos doc sont accessibles via le web.
@+
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68670

  • frederic34
  • Portrait de frederic34
  • Hors ligne
  • Gold Boarder
  • @NetLogic
  • Messages : 1263
  • Remerciements reçus 338
  • Karma: 60
philazerty écrit:
Bonjour
vous dites vos documents sont à la racine ?
Ne devriez vous pas avoir dans ce cas :
$dolibarr_main_data_root='/srv/data/web/vhosts/www.tasociete.com/documents';
Curieuse installation sinon car vos doc sont accessibles via le web.
@+
Bonjour
Il a surement mis un .htaccess dans le dossier documents avec:
Order allow,deny
Deny from all

Fred
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68671

Bonjour
Est-ce que:
viewimage.php?cache=1&modulepart=companylogo&file=logo-societe.jpg

renvoie l'image originale et pas le thumbnail
et est ce que tu as le dossier thumbs avec les miniatures?

Non Fred je n'arrive pas à accéder au ficher original en passant pas la route indiquée, j'ai un carré blanc qui apparaît à la place (voir pièce-jointe).
Le dossier thumbs est bien là avec les fichiers miniatures à l’intérieur que je peux télécharger via ftp et ouvrir correctement.

philazerty je me suis mal exprimé, je voulais dire à la racine du dossier ou se trouve dolibarr autrement dit dolibarr/documents

De plus, comme l'a dit Fred, il y a un .htaccess qui empêche l'accès au dossier via le web.

Sk1z0 php5-gd m'a l'air en fonction d'après le php info ...
Pièces jointes :
Dernière édition: il y a 3 ans 3 mois par j-francoisbaron.
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68672

  • frederic34
  • Portrait de frederic34
  • Hors ligne
  • Gold Boarder
  • @NetLogic
  • Messages : 1263
  • Remerciements reçus 338
  • Karma: 60
Bonjour
Peux tu m'envoyer le lien d'accès de la page login à frederic point france chez free point fr?

Fred
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68673

Désolé Fred mais je tiens à ne pas transmettre cette information pour le moment (quitte à réinstaller l'outil).
Je comprends que cette information pourrais faire avancer les choses mais je ne peux pas car il y a des données sensibles.
Merci de ta compréhension.
L'administrateur a désactivé l'accès en écriture pour le public.

logo société disparu après mise à jour il y a 3 ans 3 mois #68674

  • frederic34
  • Portrait de frederic34
  • Hors ligne
  • Gold Boarder
  • @NetLogic
  • Messages : 1263
  • Remerciements reçus 338
  • Karma: 60
Bonjour
Je ne demandais bien sûr que la page de login et aucun accès à tes données. Peux tu d'un clic droit enregistrer l'image qui ne veux pas s'afficher et m'envoyer ce contenu?

Fred
L'administrateur a désactivé l'accès en écriture pour le public.