Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Problème avec mon fichier lang

Problème avec mon fichier lang il y a 9 ans 7 mois #20114

  • ocarette
  • Portrait de ocarette
  • Hors ligne
  • Fresh Boarder
  • Messages : 14
  • Remerciements reçus 1
  • Karma: 1
Bonsoir,
Je suis en train de créer un petit module pour SPIP (modification du statut dans spip et avoir des systèmes automatisé avec des taches cron pour laisser l'accès au site privé ou non selon l'adhésion à notre association)

Lors de la création de mon fichier spip.lang, les accents ne sont pas géré et les données ne sont pas affichée lorsqu'on utilisate $langs->trans().
# Dolibarr language file - fr_FR - spip
CHARSET=UTF-8
ModifSucess=Modification réussie
si on met
$langs->trans("ModifSuccess")
rien ne s'affiche.
si je supprime l'accent le message s'affiche.

Quelqu'un peut-il m'orienter sur le problème ?

Merci par avance.

Olivier
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Problème avec mon fichier lang il y a 9 ans 7 mois #20167

  • eldy
  • Portrait de eldy
  • Hors ligne
  • Administrateur
  • Messages : 1054
  • Remerciements reçus 50
  • Karma: 107
Vérifie que le logiciel que tu utilise pour créer le ficier langue enregistre bien ton fichier lang au format UTF8.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Problème avec mon fichier lang il y a 9 ans 7 mois #20545

  • ocarette
  • Portrait de ocarette
  • Hors ligne
  • Fresh Boarder
  • Messages : 14
  • Remerciements reçus 1
  • Karma: 1
Comment puis-je vérifier cela ?
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Problème avec mon fichier lang il y a 9 ans 7 mois #20547

  • regis
  • Portrait de regis
  • Hors ligne
  • Administrateur
  • Messages : 2073
  • Remerciements reçus 103
  • Karma: 140
tu utilises quoi pour développer ?
perso j'utilise "Eclipse PDT All In Ones"

www.eclipse.org/pdt/downloads/
L'administrateur a désactivé l'accès en écriture pour le public.