Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Connexion impossible...

Connexion impossible... il y a 2 semaines 1 jour #103553

  • grandware
  • Portrait de grandware
  • Hors ligne
  • Amiral
  • Messages : 2
  • Karma: 0
Bonjour à tous,

Mille excuse si je poste au mauvais endroit... Installation... Mise à jour...

Mon Dolibarr est hébergé chez OVH sur le serveur de mon site Web (wordpress). Apres "forçage" du site en https et migration du PHP en 7.2, je ne peux plus me connecter et je récupère le message suivant :

DolibarrHasDetectedError.
InformationToHelpDiagnose:
Date: 20181124170738
Dolibarr: 8.0.2
PHP: 7.2.10
Server: Apache
OS: Linux webm332.20gp.ha.ovh.net 4.14.66-ovh-vps-grsec-zfs-classid #1 SMP Thu Aug 23 15:15:40 CEST 2018 x86_64
UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36

RequestedUrl: /dolibarr/htdocs/
Referer:
MenuManager:

DatabaseTypeManager: mysqli
RequestLastAccessInError: ErrorNoRequestInError
ReturnCodeLastAccessInError: ErrorNoRequestInError
InformationLastAccessInError: ErrorNoRequestInError

Message: host=sql19.modules, port=0, user=4316588-1, databasename=4316588-1, mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file

Any idea du samedi soir ??

Merci d'avance

Christophe
L'administrateur a désactivé l'accès en écriture pour le public.

Connexion impossible... il y a 2 semaines 3 heures #103571

  • Arre
  • Portrait de Arre
  • Hors ligne
  • Gold Boarder
  • Messages : 889
  • Remerciements reçus 179
  • Karma: 30
Salut grandware,

à priori ton problème vient de ton hébergement et pas de dolibarr.

Arrives tu as accéder à ta base de données via l'interface d'OVH / phpmyadmin ?

Si oui, vérifie les paramètres de ton hébergement OVH et check ton fichier conf.php dans dolibarr ... la simple "mise à jour" de php t'a peut être changé certains paramètres chez OVH (surtout en mutualsé)
L'administrateur a désactivé l'accès en écriture pour le public.

Connexion impossible... il y a 2 semaines 11 minutes #103573

  • ksar
  • Portrait de ksar
  • Hors ligne
  • Gold Boarder
  • Bijour!
  • Messages : 388
  • Remerciements reçus 120
  • Karma: 7
Bonjour,

C'est écrit en toute lettre : mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password')

Il faut changer le mot de pass de l'utilisateur MYSQL
L'administrateur a désactivé l'accès en écriture pour le public.

Connexion impossible... il y a 1 semaine 6 jours #103610

  • grandware
  • Portrait de grandware
  • Hors ligne
  • Amiral
  • Messages : 2
  • Karma: 0
C'est bon, j'ai modifié le mot de passe et tout est revenu dans l'ordre.

Le problème principal venait que la base avait été créée avec un module 1-click et qu'il a fallut le bon lien pour exécuter le phpmyadmin idoine.

Merci de votre aide !!
L'administrateur a désactivé l'accès en écriture pour le public.