Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Problème installation UTF-8

Problème installation UTF-8 il y a 1 an 9 mois #89518

  • Nrvnqsr
  • Portrait de Nrvnqsr
  • Hors ligne
  • Junior Boarder
  • Administrateur Systèmes
  • Messages : 21
  • Karma: 0
Bonjour,

Lors d'une installation ( FreeBSD 11.1 / Apache 2.4 / PHP 7.1 / MariaDB 10.2 / Dolibarr 6.0.3 ) je rencontre le warning suivant :
Error Ce PHP ne prend pas en charge les fonctions UTF8. Résolvez le problème avant d'installer Dolibarr car il ne pourra pas fonctionner correctement.

J'veux bien resolver le problème ma bonne dame, mais dans mon php.ini, il me semble bien que mon default charset est UTF-8...
[email protected]:/usr/local/www/apache24/data # cat /usr/local/etc/php.ini | grep default_charset
default_charset = "UTF-8"

Une vérification dans le PHPinfo plus tard me confirme que mon défaut charset est bien UTF-8, Mystère donc.

Je vais pour l'instant continuer l'installation et vous tiens informés.
L'administrateur a désactivé l'accès en écriture pour le public.

Problème installation UTF-8 il y a 1 an 9 mois #89550

  • frederic34
  • Portrait de frederic34
  • Hors ligne
  • Gold Boarder
  • @NetLogic
  • Messages : 1263
  • Remerciements reçus 338
  • Karma: 60
Bonjour
Il manque la fonction utf8_encode à ton php

Recherche le paquet qu'il te manque en fonction de ta distribution.

Fred
L'administrateur a désactivé l'accès en écriture pour le public.

Problème installation UTF-8 il y a 1 an 8 mois #90471

  • vm500
  • Portrait de vm500
  • Hors ligne
  • Fresh Boarder
  • Messages : 4
  • Karma: 0
Bonjour ,

J'avais la même erreur puis j'ai installé phpXXX-mbstring
L'administrateur a désactivé l'accès en écriture pour le public.

Problème installation UTF-8 il y a 6 mois 1 semaine #106642

  • afenioux
  • Portrait de afenioux
  • Hors ligne
  • Fresh Boarder
  • Messages : 1
  • Karma: 0
sous Debian :
apt-get install php7.0-xml
L'administrateur a désactivé l'accès en écriture pour le public.