Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi
  • Page :
  • 1
  • 2

SUJET : Liste complète des TAGS

Liste complète des TAGS il y a 1 an 2 semaines #100126

  • sebmas
  • Portrait de sebmas
  • Hors ligne
  • Expert Boarder
  • Messages : 151
  • Remerciements reçus 8
  • Karma: 1
Là ou c'est dingue c'est quil y a un exemple en 7.0.3 avec d'autres champs pas listé ci-dessus :

__(Hello)__,

__(ThisIsContentOfYourCard)__
__(ID)__ : __ID__
__(Civiliyty)__ : __MEMBER_CIVILITY__
__(Firstname)__ : __MEMBER_FIRSTNAME__
__(Lastname)__ : __MEMBER_LASTNAME__
__(Fullname)__ : __MEMBER_FULLNAME__
__(Company)__ : __MEMBER_COMPANY__
__(Address)__ : __MEMBER_ADDRESS__
__(Zip)__ : __MEMBER_ZIP__
__(Town)__ : __MEMBER_TOWN__
__(Country)__ : __MEMBER_COUNTRY__
__(Email)__ : __MEMBER_EMAIL__
__(Birthday)__ : __MEMBER_BIRTH__
__(Photo)__ : __MEMBER_PHOTO__
__(Login)__ : __MEMBER_LOGIN__
__(Password)__ : __MEMBER_PASSWORD__
__(Phone)__ : __MEMBER_PHONE__
__(PhonePerso)__ : __MEMBER_PHONEPRO__
__(PhoneMobile)__ : __MEMBER_PHONEMOBILE__
L'administrateur a désactivé l'accès en écriture pour le public.

Liste complète des TAGS il y a 1 an 2 semaines #100128

  • fred1
  • Portrait de fred1
  • Hors ligne
  • Senior Boarder
  • Messages : 56
  • Remerciements reçus 14
  • Karma: 0
j'ai vérifié sur une autre install en 7.0.3 et même en 8.0.1 le __CONTACTCIVNAME__ est parti
L'administrateur a désactivé l'accès en écriture pour le public.

Liste complète des TAGS il y a 1 an 2 semaines #100284

  • frederic34
  • Portrait de frederic34
  • Hors ligne
  • Gold Boarder
  • @NetLogic
  • Messages : 1266
  • Remerciements reçus 339
  • Karma: 60
Bonjour

Consultez ceci github.com/Dolibarr/dolibarr/pull/9099

Fred
L'administrateur a désactivé l'accès en écriture pour le public.

Liste complète des TAGS il y a 1 an 1 semaine #100290

  • yves57
  • Portrait de yves57
  • Hors ligne
  • Gold Boarder
  • Messages : 670
  • Remerciements reçus 138
  • Karma: 11
Merci Frédéric.
Donc de manière plus explicite, à partir de la version 8, __CONTACTCIVNAME__ n'existe plus et est remplacé par les clés suivantes, en fonction de la qualité du contact :
__CONTACT_NAME_BILLING__
__CONTACT_NAME_CUSTOMER__
__CONTACT_NAME_SHIPPING__
__CONTACT_NAME_SERVICE__
@Frédéric : c'est bien ça ?
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: frederic34

Liste complète des TAGS il y a 1 an 1 semaine #100292

  • frederic34
  • Portrait de frederic34
  • Hors ligne
  • Gold Boarder
  • @NetLogic
  • Messages : 1266
  • Remerciements reçus 339
  • Karma: 60
Bonjour

Oui c'est par rapport au type de contact. C'est par un message de la mailing list dev que j'ai vu ça. Tu peux t'y inscrire.

Fred
L'administrateur a désactivé l'accès en écriture pour le public.

Liste complète des TAGS il y a 1 an 1 semaine #100296

  • yves57
  • Portrait de yves57
  • Hors ligne
  • Gold Boarder
  • Messages : 670
  • Remerciements reçus 138
  • Karma: 11
Merci Frédéric,
J'ai souscrit à la liste. Je doute que je sois submergé ;)
Ceci me fait prendre conscience qu'il manque une fonction importante dans le projet : retranscrire en documentation les évolutions et nouvelles fonctionnalités ajoutées.
Ceci transparait dans le vécu, par ce fil par exemple, par le caractère brut du changelog qu'on reçoit à chaque publication, et par l'organisation mise en place. On a des développeurs avec différents grades, mais aucune fonction pour faire le lien entre ce qui est codé et la documentation. La fonction pour le wiki n'est que de maintenir le wiki en place. L'utilisateur doit être PHP et GIT fluent pour savoir quelle fonction existe et comment l'utiliser.
L'administrateur a désactivé l'accès en écriture pour le public.

Liste complète des TAGS il y a 1 an 1 semaine #100388

  • fred1
  • Portrait de fred1
  • Hors ligne
  • Senior Boarder
  • Messages : 56
  • Remerciements reçus 14
  • Karma: 0
Merci à vous deux pour cette explication :laugh:

Il est vrai que la modification n'est pas très "user friendly" et peut apparaître comme une régression si on ne suit pas les dev en cours.
Ce serait bien de faire un lien sur les améliorations fonctionnelles mais plus orienté utilisateur pour les montées en version.

Pour vérifier, on trouve les valeurs XXX dans configuration / Dictionnaires - Types de contacts/adresses
ou pour les clients on a les valeurs suivantes :
BILLING
SERVICE
SHIPPING
Dernière édition: il y a 1 an 1 semaine par fred1.
L'administrateur a désactivé l'accès en écriture pour le public.

Liste complète des TAGS il y a 6 mois 4 semaines #107165

  • Sylvain.Legrand
  • Portrait de Sylvain.Legrand
  • Hors ligne
  • Modérateur
  • Rien n'est simple, tout est compliqué !
  • Messages : 859
  • Remerciements reçus 183
  • Karma: 26
Bonjour,

Je déterre le sujet car en V8.0.4 sous Linux (PHP 7.2) j'ai le même phénomène ! :sick:

Je n'utilise pas les modèles de mail.
La commande est créée, validée avec des contacts clients assignés.
L'aide concernant la saisie du corps du message indique bien les variables disponibles et ces 3 là (__CONTACT_NAME_BILLING__ , __CONTACT_NAME_CUSTOMER__ , __CONTACT_NAME_SHIPPING__) sont renseignées avec le nom du contact correctement associé.

Je copie donc la variable désirée dans le corps du message, j'envoi => message d'envoi OK ! :)

Le message est reçu par le destinataire avec __CONTACT_NAME_CUSTOMER__ à la place de son nom ! :woohoo:

Le log activé en mode DEBUG n'indique rien de spécial (voir fichier joint

Fichier attaché :

Nom du fichier : dolibarr.zip
Taille du ficher : 13 KB
) !

Cordialement,
Sylvain Legrand.
Dernière édition: il y a 6 mois 4 semaines par Sylvain.Legrand.
L'administrateur a désactivé l'accès en écriture pour le public.

Liste complète des TAGS il y a 6 mois 4 semaines #107192

  • madlye
  • Portrait de madlye
  • Hors ligne
  • Senior Boarder
  • Messages : 58
  • Remerciements reçus 6
  • Karma: 0
Bonjour,
Nous avons fait une découverte en v8.03, je ne sais pas si cela pourra vous aider mais....
Lorsque vous êtes sur votre commande, sur le bouton @envoyer par email , vous trouverez à côté de "message" un petit icône "?" C'est ici que nous avons trouvé les BONNES variable, qui pour info, ne sont pas les même que celle données dans le module modèles de mail. Lorsque dans la commande vous y rajouter des contactes, vos variables seront enrichies par des nouvelles (exemple: client suivi commande etc) cela marche aussi pour contrat, propales etc...)
L'administrateur a désactivé l'accès en écriture pour le public.

Liste complète des TAGS il y a 6 mois 4 semaines #107204

  • Sylvain.Legrand
  • Portrait de Sylvain.Legrand
  • Hors ligne
  • Modérateur
  • Rien n'est simple, tout est compliqué !
  • Messages : 859
  • Remerciements reçus 183
  • Karma: 26
Bonjour,

Merci de votre réponse.
C'est bien là ou vous l'indiquez que j'ai pris le nom des variables. D'autre part comme je l'ai dit dans mon post précédent ces variables ont bien une valeur affectée (la bonne) => quand je clique sur le bouton d'aide '?' tout parait correct !

Quand j'envoi le message ... :sick: ... plus rien ne vas puisque le mécanisme de substitution ne fonctionne pas.

Un détail supplémentaire : j'utilise le module externe multi-sociétés.

Cordialement,
Sylvain Legrand.
L'administrateur a désactivé l'accès en écriture pour le public.
  • Page :
  • 1
  • 2